about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/email.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-01-30T16·06+0300
committertazjin <tazjin@tvl.su>2022-01-31T16·11+0000
commitaa122cbae78ce97d60c0c98ba14df753d97e40b1 (patch)
tree12b98d85c4b18fe870feb26de70db9ba61837bd7 /users/grfn/system/home/modules/email.nix
parent2d10d60fac0fd00a71b65cfdcb9fba0477b2086c (diff)
style: format entire depot with nixpkgs-fmt r/3723
This CL can be used to compare the style of nixpkgs-fmt against other
formatters (nixpkgs, alejandra).

Change-Id: I87c6abff6bcb546b02ead15ad0405f81e01b6d9e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4397
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Reviewed-by: wpcarro <wpcarro@gmail.com>
Reviewed-by: Profpatsch <mail@profpatsch.de>
Reviewed-by: kanepyork <rikingcoding@gmail.com>
Reviewed-by: tazjin <tazjin@tvl.su>
Reviewed-by: cynthia <cynthia@tvl.fyi>
Reviewed-by: edef <edef@edef.eu>
Reviewed-by: eta <tvl@eta.st>
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'users/grfn/system/home/modules/email.nix')
-rw-r--r--users/grfn/system/home/modules/email.nix64
1 files changed, 35 insertions, 29 deletions
diff --git a/users/grfn/system/home/modules/email.nix b/users/grfn/system/home/modules/email.nix
index 0a3e58205b..63dfeeb6f4 100644
--- a/users/grfn/system/home/modules/email.nix
+++ b/users/grfn/system/home/modules/email.nix
@@ -9,7 +9,8 @@ let
     let
       good = upperChars ++ lowerChars ++ stringToCharacters "0123456789-_";
       subst = c: if any (x: x == c) good then c else "-";
-    in stringAsChars subst name;
+    in
+    stringAsChars subst name;
 
   accounts = {
     personal = {
@@ -26,7 +27,8 @@ let
 
   };
 
-in {
+in
+{
   programs.lieer.enable = true;
   programs.notmuch.enable = true;
   services.lieer.enable = true;
@@ -37,16 +39,18 @@ in {
     msmtp
   ];
 
-  systemd.user.services = mapAttrs' (name: account: {
-    name = escapeUnitName "lieer-${name}";
-    value.Service = {
-      ExecStart = mkForce "${pkgs.writeShellScript "sync-${name}" ''
+  systemd.user.services = mapAttrs'
+    (name: account: {
+      name = escapeUnitName "lieer-${name}";
+      value.Service = {
+        ExecStart = mkForce "${pkgs.writeShellScript "sync-${name}" ''
         ${pkgs.gmailieer}/bin/gmi sync --path ~/mail/${name}
       ''}";
-      Environment = "NOTMUCH_CONFIG=${config.home.sessionVariables.NOTMUCH_CONFIG}";
-    };
+        Environment = "NOTMUCH_CONFIG=${config.home.sessionVariables.NOTMUCH_CONFIG}";
+      };
 
-  }) accounts;
+    })
+    accounts;
 
   # xdg.configFile."notifymuch/notifymuch.cfg".text = generators.toINI {} {
   #   notifymuch = {
@@ -58,30 +62,32 @@ in {
   # };
 
   accounts.email.maildirBasePath = "mail";
-  accounts.email.accounts = mapAttrs (_: params@{ passEntry, ... }: {
-    realName = "Griffin Smith";
-    passwordCommand = "pass ${passEntry}";
+  accounts.email.accounts = mapAttrs
+    (_: params@{ passEntry, ... }: {
+      realName = "Griffin Smith";
+      passwordCommand = "pass ${passEntry}";
 
-    flavor = "gmail.com";
+      flavor = "gmail.com";
 
-    imapnotify = {
-      enable = true;
-      boxes = [ "Inbox" ];
-    };
+      imapnotify = {
+        enable = true;
+        boxes = [ "Inbox" ];
+      };
 
-    gpg = {
-      key = "0F11A989879E8BBBFDC1E23644EF5B5E861C09A7";
-      signByDefault = true;
-    };
+      gpg = {
+        key = "0F11A989879E8BBBFDC1E23644EF5B5E861C09A7";
+        signByDefault = true;
+      };
 
-    notmuch.enable = true;
-    lieer = {
-      enable = true;
-      sync = {
+      notmuch.enable = true;
+      lieer = {
         enable = true;
-        frequency = "*:*";
+        sync = {
+          enable = true;
+          frequency = "*:*";
+        };
       };
-    };
-    msmtp.enable = true;
-  } // builtins.removeAttrs params ["passEntry"]) accounts;
+      msmtp.enable = true;
+    } // builtins.removeAttrs params [ "passEntry" ])
+    accounts;
 }