about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/email.nix
diff options
context:
space:
mode:
authorsterni <sternenseemann@systemli.org>2022-09-26T17·33+0200
committersterni <sternenseemann@systemli.org>2022-09-28T08·02+0000
commit0c178a0ef61d2f5f4d6169c7a951663c62509cd7 (patch)
tree08d4b97e5d423f9624211f92700e8bd1cf27fcbc /users/grfn/system/home/modules/email.nix
parentf40283e0985b5e16a7d67e018a16b0d52f09b90c (diff)
chore(3p/sources): Bump channels & overlays r/4980
Upstream nixpkgs removed a lot of aliases this time, so we needed to do
the following transformations. It's a real shame that aliases only
really become discoverable easily when they are removed.

* runCommandNoCC -> runCommand
* gmailieer -> lieer
  We also need to work around the fact that home-manager hasn't catched
  on to this rename.
* mysql -> mariadb
* pkgconfig -> pkg-config
  This also affects our Nix fork which needs to be bumped.
* prometheus_client -> prometheus-client
* rxvt_unicode -> rxvt-unicode-unwrapped
* nix-review -> nixpkgs-review
* oauth2_proxy -> oauth2-proxy

Additionally, some Go-related builders decided to drop support for
passing the sha256 hash in directly, so we need to use the generic hash
arguments.

Change-Id: I84aaa225ef18962937f8616a9ff064822f0d5dc3
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6792
Autosubmit: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Reviewed-by: flokli <flokli@flokli.de>
Reviewed-by: tazjin <tazjin@tvl.su>
Reviewed-by: wpcarro <wpcarro@gmail.com>
Diffstat (limited to 'users/grfn/system/home/modules/email.nix')
-rw-r--r--users/grfn/system/home/modules/email.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/users/grfn/system/home/modules/email.nix b/users/grfn/system/home/modules/email.nix
index 4d5f3df69587..55dd70529b9b 100644
--- a/users/grfn/system/home/modules/email.nix
+++ b/users/grfn/system/home/modules/email.nix
@@ -29,6 +29,10 @@ let
 
 in
 {
+  # 2022-09-26: workaround for home-manager defaulting to removed pkgs.gmailieer
+  # attribute, can likely be removed soon
+  programs.lieer.package = pkgs.lieer;
+
   programs.lieer.enable = true;
   programs.notmuch.enable = true;
   services.lieer.enable = true;
@@ -45,7 +49,7 @@ in
       name = escapeUnitName "lieer-${name}";
       value.Service = {
         ExecStart = mkForce "${pkgs.writeShellScript "sync-${name}" ''
-        ${pkgs.gmailieer}/bin/gmi sync --path ~/mail/${name}
+        ${pkgs.lieer}/bin/gmi sync --path ~/mail/${name}
       ''}";
         Environment = "NOTMUCH_CONFIG=${config.home.sessionVariables.NOTMUCH_CONFIG}";
       };