about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/development/rust.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2022-06-14T14·15-0400
committerclbot <clbot@tvl.fyi>2022-07-11T14·43+0000
commitbdf614ec3df400c7682f4ca4ec9a488ab7b3691f (patch)
tree6b923558d4b9e60239d0cf7807c68b06a9238c77 /users/grfn/system/home/modules/development/rust.nix
parent8300d889c50552c3ce5fa8e86b6f604367bf5659 (diff)
feat(grfn/home): Install some new rust utilities r/4284
Change-Id: I9e210a86a037c58aa832b25203b5ac8c27306aa3
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5933
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Autosubmit: grfn <grfn@gws.fyi>
Diffstat (limited to '')
-rw-r--r--users/grfn/system/home/modules/development/rust.nix14
1 files changed, 12 insertions, 2 deletions
diff --git a/users/grfn/system/home/modules/development/rust.nix b/users/grfn/system/home/modules/development/rust.nix
index 4ae5bc3bcc..95a9ad1a91 100644
--- a/users/grfn/system/home/modules/development/rust.nix
+++ b/users/grfn/system/home/modules/development/rust.nix
@@ -1,18 +1,28 @@
 { config, lib, pkgs, ... }:
 
-
+let
+  inherit (config.lib) depot;
+in
 {
+
   home.packages = with pkgs; [
     rustup
     rust-analyzer
     cargo-edit
     cargo-expand
-    cargo-flamegraph
     cargo-rr
     cargo-udeps
     cargo-bloat
     sccache
     evcxr
+
+    depot.users.grfn.pkgs.cargo-hakari
+    depot.users.grfn.pkgs.cargo-nextest
+
+    # benchmarking+profiling
+    cargo-criterion
+    cargo-flamegraph
+    coz
   ];
 
   programs.zsh.shellAliases = {