about summary refs log tree commit diff
path: root/users/grfn/system/home/modules/desktop.nix
diff options
context:
space:
mode:
authorAspen Smith <grfn@gws.fyi>2024-02-12T03·00-0500
committerclbot <clbot@tvl.fyi>2024-02-14T19·37+0000
commit82ecd61f5c699cf3af6c4eadf47a1c52b1d696c6 (patch)
tree429c5e078528000591742ec3211bc768ae913a78 /users/grfn/system/home/modules/desktop.nix
parent0ba476a4266015f278f18d74094299de74a5a111 (diff)
chore(users): grfn -> aspen r/7511
Change-Id: I6c6847fac56f0a9a1a2209792e00a3aec5e672b9
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10809
Autosubmit: aspen <root@gws.fyi>
Reviewed-by: sterni <sternenseemann@systemli.org>
Tested-by: BuildkiteCI
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'users/grfn/system/home/modules/desktop.nix')
-rw-r--r--users/grfn/system/home/modules/desktop.nix45
1 files changed, 0 insertions, 45 deletions
diff --git a/users/grfn/system/home/modules/desktop.nix b/users/grfn/system/home/modules/desktop.nix
deleted file mode 100644
index cab3b658e031..000000000000
--- a/users/grfn/system/home/modules/desktop.nix
+++ /dev/null
@@ -1,45 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-# Things that only work in the presence of a linux desktop environment
-
-{
-  imports = [
-    ./i3.nix
-    ./obs.nix
-    ./games.nix
-  ];
-
-  home.packages = with pkgs; [
-    (ntfy.override {
-      # Slack support is broken as of 2023-06-15
-      withSlack = false;
-    })
-    (writeShellApplication {
-      name = "edit-input";
-
-      runtimeInputs = [ xdotool xclip ];
-      text = ''
-        set -euo pipefail
-
-        sleep 0.2
-        xdotool key ctrl+a ctrl+c
-        xclip -out -selection clipboard > /tmp/EDIT
-        emacsclient -c /tmp/EDIT
-        xclip -in -selection clipboard < /tmp/EDIT
-        sleep 0.2
-        xdotool key ctrl+v
-        rm /tmp/EDIT
-      '';
-    })
-  ];
-
-  services.syncthing.tray.enable = true;
-
-  gtk = {
-    enable = true;
-    gtk3.bookmarks = [
-      "file:///home/grfn/code"
-      "file:///home/grfn/notes"
-    ];
-  };
-}