about summary refs log tree commit diff
path: root/users/grfn/system/home/machines/yeren.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2021-09-02T16·42-0400
committergrfn <grfn@gws.fyi>2021-09-02T17·05+0000
commit930a11d009715c2309793135543daa36e0896199 (patch)
tree4f9f8d4e2a94af6ce06aafcfec97e22513e0ee0b /users/grfn/system/home/machines/yeren.nix
parent3ce45e8d9fcf2d881e153d0026a071edd221b1eb (diff)
feat(gs/system): Conditionally add private.nix r/2821
I have some secret stuff here (not security-secret, just secret that I'm
installing it in my system) so this has to be conditionally included

Change-Id: Idb12e5bbab507ad3dc5eb610199fd384789c0e20
Reviewed-on: https://cl.tvl.fyi/c/depot/+/3491
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to '')
-rw-r--r--users/grfn/system/home/machines/yeren.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/users/grfn/system/home/machines/yeren.nix b/users/grfn/system/home/machines/yeren.nix
index 38bab02995..cb36c89736 100644
--- a/users/grfn/system/home/machines/yeren.nix
+++ b/users/grfn/system/home/machines/yeren.nix
@@ -1,6 +1,7 @@
 { pkgs, lib, config, ... }:
 
 let
+  inherit (builtins) pathExists;
   laptopKeyboardId = "5";
 in
 
@@ -9,7 +10,7 @@ in
     ../platforms/linux.nix
     ../modules/common.nix
     ../modules/development/readyset.nix
-  ];
+  ] ++ (lib.optional (pathExists ../modules/private.nix) ../modules/private.nix);
 
   # for when hacking
   programs.home-manager.enable = true;