about summary refs log tree commit diff
path: root/users/grfn/system/home/machines/roswell.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2022-05-31T19·34-0400
committerclbot <clbot@tvl.fyi>2022-05-31T19·38+0000
commit8851075c2764fecde2a112815d7958d5d29fb406 (patch)
tree3d145c5855117324d33382b6c9d75b8e5c606701 /users/grfn/system/home/machines/roswell.nix
parentfb228861656a7dff2d3619a7b4b70bce26152b23 (diff)
feat(grfn/system): Resuscitate roswell r/4195
Resuscitate the configuration for roswell, the semi-portable
configuration I use for ec2 development boxes. Lots of the changes here
are trying to get Tramp working.

Change-Id: I2dc2fd1d9aa76e145fa3f3f847af761cb652ab47
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5798
Reviewed-by: grfn <grfn@gws.fyi>
Autosubmit: grfn <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/grfn/system/home/machines/roswell.nix')
-rw-r--r--users/grfn/system/home/machines/roswell.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/users/grfn/system/home/machines/roswell.nix b/users/grfn/system/home/machines/roswell.nix
index ee3a557fa0..a5a32fa586 100644
--- a/users/grfn/system/home/machines/roswell.nix
+++ b/users/grfn/system/home/machines/roswell.nix
@@ -1,7 +1,7 @@
 { pkgs, lib, config, ... }:
 
 let
-  laptopKeyboardId = "5";
+  inherit (builtins) pathExists;
 in
 
 {
@@ -11,7 +11,9 @@ in
     ../modules/development.nix
     ../modules/emacs.nix
     ../modules/vim.nix
-  ];
+    ../modules/development/readyset.nix
+    ../modules/tmux.nix
+  ] ++ (lib.optional (pathExists ../modules/private.nix) ../modules/private.nix);
 
   home.packages = with pkgs; [
     # System utilities
@@ -36,6 +38,12 @@ in
     nix-prefetch-github
     nix-review
     cachix
+
+    # ReadySet stuff
+    nodejs
+    mysql80
+
+    (writeShellScriptBin "xdg-open" "echo xdg-open: \"$@\"")
   ];
 
   programs.password-store.enable = true;