about summary refs log tree commit diff
path: root/users/grfn/pkgs/cargo-nextest.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2022-06-14T14·15-0400
committerclbot <clbot@tvl.fyi>2022-07-11T14·43+0000
commitbdf614ec3df400c7682f4ca4ec9a488ab7b3691f (patch)
tree6b923558d4b9e60239d0cf7807c68b06a9238c77 /users/grfn/pkgs/cargo-nextest.nix
parent8300d889c50552c3ce5fa8e86b6f604367bf5659 (diff)
feat(grfn/home): Install some new rust utilities r/4284
Change-Id: I9e210a86a037c58aa832b25203b5ac8c27306aa3
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5933
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Autosubmit: grfn <grfn@gws.fyi>
Diffstat (limited to 'users/grfn/pkgs/cargo-nextest.nix')
-rw-r--r--users/grfn/pkgs/cargo-nextest.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/users/grfn/pkgs/cargo-nextest.nix b/users/grfn/pkgs/cargo-nextest.nix
new file mode 100644
index 0000000000..5339a6e600
--- /dev/null
+++ b/users/grfn/pkgs/cargo-nextest.nix
@@ -0,0 +1,27 @@
+{ pkgs, ... }:
+
+with pkgs;
+
+rustPlatform.buildRustPackage rec {
+  pname = "cargo-nextest";
+  version = "0.9.14";
+
+  src = fetchFromGitHub {
+    owner = "nextest-rs";
+    repo = "nextest";
+    rev = "cargo-nextest-${version}";
+    sha256 = "0nc8xz90m03yydj7zafjgciv4vxwzbz814pnjdi49ddkr4q20sc3";
+  };
+
+  cargoSha256 = "0rcsh573qryllgc199ah2dbrn1xcp215q2xkjb3f4ps757m7scnm";
+
+  cargoTestFlags = [
+    "--"
+    "--skip"
+    "tests_integration::test_relocated_run"
+    "--skip"
+    "tests_integration::test_run"
+    "--skip"
+    "tests_integration::test_run_after_build"
+  ];
+}