about summary refs log tree commit diff
path: root/users/grfn/pkgs/cargo-hakari.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2022-06-14T14·15-0400
committerclbot <clbot@tvl.fyi>2022-07-11T14·43+0000
commitbdf614ec3df400c7682f4ca4ec9a488ab7b3691f (patch)
tree6b923558d4b9e60239d0cf7807c68b06a9238c77 /users/grfn/pkgs/cargo-hakari.nix
parent8300d889c50552c3ce5fa8e86b6f604367bf5659 (diff)
feat(grfn/home): Install some new rust utilities r/4284
Change-Id: I9e210a86a037c58aa832b25203b5ac8c27306aa3
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5933
Tested-by: BuildkiteCI
Reviewed-by: grfn <grfn@gws.fyi>
Autosubmit: grfn <grfn@gws.fyi>
Diffstat (limited to 'users/grfn/pkgs/cargo-hakari.nix')
-rw-r--r--users/grfn/pkgs/cargo-hakari.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/users/grfn/pkgs/cargo-hakari.nix b/users/grfn/pkgs/cargo-hakari.nix
new file mode 100644
index 000000000000..b6f4e7e40007
--- /dev/null
+++ b/users/grfn/pkgs/cargo-hakari.nix
@@ -0,0 +1,27 @@
+{ pkgs, ... }:
+
+with pkgs;
+
+rustPlatform.buildRustPackage rec {
+  pname = "cargo-hakari";
+  version = "0.9.13";
+
+  src = fetchFromGitHub {
+    owner = "facebookincubator";
+    repo = "cargo-guppy";
+    rev = "cargo-hakari-${version}";
+    sha256 = "11ds2zryxdd6rvszkpphb0xnfg7rqisg6kixrwyiydjrm5rdjg9d";
+  };
+
+  cargoSha256 = "0b2hjyak5v4m3g5zjk2q8bdb4iv3015qw1rmhpclv4cv48lcmdbb";
+
+  buildAndTestSubdir = "tools/cargo-hakari";
+
+  nativeBuildInputs = [
+    pkg-config
+  ];
+
+  buildInputs = [
+    openssl
+  ];
+}