about summary refs log tree commit diff
path: root/users/grfn/gws.fyi/orgExportHTML.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-01-30T16·06+0300
committertazjin <tazjin@tvl.su>2022-01-31T16·11+0000
commitaa122cbae78ce97d60c0c98ba14df753d97e40b1 (patch)
tree12b98d85c4b18fe870feb26de70db9ba61837bd7 /users/grfn/gws.fyi/orgExportHTML.nix
parent2d10d60fac0fd00a71b65cfdcb9fba0477b2086c (diff)
style: format entire depot with nixpkgs-fmt r/3723
This CL can be used to compare the style of nixpkgs-fmt against other
formatters (nixpkgs, alejandra).

Change-Id: I87c6abff6bcb546b02ead15ad0405f81e01b6d9e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4397
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Reviewed-by: wpcarro <wpcarro@gmail.com>
Reviewed-by: Profpatsch <mail@profpatsch.de>
Reviewed-by: kanepyork <rikingcoding@gmail.com>
Reviewed-by: tazjin <tazjin@tvl.su>
Reviewed-by: cynthia <cynthia@tvl.fyi>
Reviewed-by: edef <edef@edef.eu>
Reviewed-by: eta <tvl@eta.st>
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'users/grfn/gws.fyi/orgExportHTML.nix')
-rw-r--r--users/grfn/gws.fyi/orgExportHTML.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/users/grfn/gws.fyi/orgExportHTML.nix b/users/grfn/gws.fyi/orgExportHTML.nix
index ac28580a59..f9cb8d38fb 100644
--- a/users/grfn/gws.fyi/orgExportHTML.nix
+++ b/users/grfn/gws.fyi/orgExportHTML.nix
@@ -25,15 +25,16 @@ let
   outName =
     if isNull headline
     then
-      let bn = builtins.baseNameOf src;
-          filename = elemAt (splitString "." bn) 0;
+      let
+        bn = builtins.baseNameOf src;
+        filename = elemAt (splitString "." bn) 0;
       in
-        if depot.nix.utils.isDirectory src
-        then filename
-        else filename + ".html"
+      if depot.nix.utils.isDirectory src
+      then filename
+      else filename + ".html"
     else "${filename}-${replaceStrings [" "] ["-"] filename}.html";
 
-  escapeDoubleQuotes = replaceStrings ["\""] ["\\\""];
+  escapeDoubleQuotes = replaceStrings [ "\"" ] [ "\\\"" ];
 
   navToHeadline = optionalString (! isNull headline) ''
     (search-forward "${escapeDoubleQuotes headline}")