about summary refs log tree commit diff
path: root/users/grfn/bbbg/module.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2021-12-27T03·48-0500
committerclbot <clbot@tvl.fyi>2021-12-27T03·52+0000
commit67942f7447571b269f0e5118a2b04081f1775b9e (patch)
tree790dd42ec8e2faf9adc095213fa5f5cdeeeae204 /users/grfn/bbbg/module.nix
parent78f2bf937154339211657a1e62217b6676cb7f5d (diff)
fix(grfn/bbbg): Configure web base url r/3458
This was originally intended to work around the issue caused by me
accidentally ending up proxy_set_header'ing the Host header twice (which
nginx *concatenates with slashes*, rather than overwriting!), but seems
sensible regardless to make that whole thing (hopefully) a bit less
brittle

Change-Id: I877fa594b46e88d1ba05e793832beab3d0aaccdd
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4697
Reviewed-by: grfn <grfn@gws.fyi>
Autosubmit: grfn <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/grfn/bbbg/module.nix')
-rw-r--r--users/grfn/bbbg/module.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/users/grfn/bbbg/module.nix b/users/grfn/bbbg/module.nix
index cff9713962..297d846f22 100644
--- a/users/grfn/bbbg/module.nix
+++ b/users/grfn/bbbg/module.nix
@@ -71,6 +71,7 @@ in {
           PGUSER = cfg.database.user;
           PGDATABASE = cfg.database.name;
           PORT = toString cfg.port;
+          BASE_URL = "https://${cfg.domain}";
         };
 
         script = "${bbbg.server}/bin/bbbg-server";