about summary refs log tree commit diff
path: root/users/glittershark/xanthous/shell.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-07-03T17·46-0400
committerglittershark <grfn@gws.fyi>2020-07-03T23·23+0000
commit6480a81c1662f75e1996aeb3cb114baf53ca09b9 (patch)
tree61367bfeca492e5139781e958fe984705a2daf3b /users/glittershark/xanthous/shell.nix
parent64ce8522fed750fcfb3a0504267f57dd20bcfb99 (diff)
feat(xan): Use haskell-language-server r/1204
Use haskell-language-server instead of haskell-ide-engine for Xanthous.

Change-Id: I7ef1433d5cd561e659fc06b3f373a6f29dfa5690
Reviewed-on: https://cl.tvl.fyi/c/depot/+/904
Tested-by: BuildkiteCI
Reviewed-by: glittershark <grfn@gws.fyi>
Reviewed-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--users/glittershark/xanthous/shell.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/users/glittershark/xanthous/shell.nix b/users/glittershark/xanthous/shell.nix
index 491f0779f8..dd747b740c 100644
--- a/users/glittershark/xanthous/shell.nix
+++ b/users/glittershark/xanthous/shell.nix
@@ -5,13 +5,11 @@
 })).shellFor {
   packages = p: [p.xanthous];
   withHoogle = true;
+  doBenchmark = true;
   buildInputs = with pkgs.haskellPackages; [
     cabal-install
     ghc-prof-flamegraph
     hp2pretty
-  ];
-
-  nativeBuildInputs = [
-    (import ./hie.nix { inherit pkgs; })
+    pkgs.haskell-language-server.ghc883
   ];
 }