about summary refs log tree commit diff
path: root/users/glittershark/xanthous/shell.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-06-29T01·27-0400
committerglittershark <grfn@gws.fyi>2020-06-29T01·56+0000
commit8091da8f0f6efd365dddf4a09555ed49c093ea50 (patch)
tree0c79b385807ba80de21a9fd2f09ec5cbb57067bc /users/glittershark/xanthous/shell.nix
parent0ecc9b4ed3e53698dc44332abd06c67a6f8ffdbb (diff)
feat(3p/haskellPackages): port in patches from xanthous r/1124
Add a few relatively uncontroversial patches to fix some broken packages
that I had developed for xanthous to the top-level third_party tree, so
they can be reused by other people in the monorepo

Change-Id: I68740477bda278c5dcc123080029ee4bd2cae37a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/740
Reviewed-by: Profpatsch <mail@profpatsch.de>
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to '')
-rw-r--r--users/glittershark/xanthous/shell.nix17
1 files changed, 9 insertions, 8 deletions
diff --git a/users/glittershark/xanthous/shell.nix b/users/glittershark/xanthous/shell.nix
index e062bf9ce1..b78844c0ee 100644
--- a/users/glittershark/xanthous/shell.nix
+++ b/users/glittershark/xanthous/shell.nix
@@ -1,16 +1,16 @@
-{ nixpkgs ? import ./nixpkgs.nix {}, compiler ? "ghc865", withHoogle ? true }:
+{ nixpkgs ? import ./nixpkgs.nix {}
+, pkgs ? nixpkgs.pkgs
+, compiler ? "ghc865"
+, withHoogle ? true
+}:
 let
-  inherit (nixpkgs) pkgs;
-
-  pkg = import ./pkg.nix { inherit nixpkgs; };
+  pkg = import ./pkg.nix { inherit pkgs; };
 
   packageSet = (
     if compiler == "default"
     then pkgs.haskellPackages
     else pkgs.haskell.packages.${compiler}
-  ).override {
-    overrides = import ./haskell-overlay.nix { inherit nixpkgs; };
-  };
+  );
 
   haskellPackages = (
     if withHoogle
@@ -18,7 +18,8 @@ let
       overrides = (self: super: {
         ghc = super.ghc // { withPackages = super.ghc.withHoogle; };
         ghcWithPackages = self.ghc.withPackages;
-      } // (import ./haskell-overlay.nix { inherit nixpkgs; }) self super);
+      } // (import ../../../third_party/haskell_overlay { inherit pkgs; })
+        self super);
     }
     else packageSet
   );