about summary refs log tree commit diff
path: root/users/glittershark/xanthous/shell.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-06-21T22·01-0400
committerglittershark <grfn@gws.fyi>2020-06-22T00·40+0000
commitaab362ef3754832e405093458747839fd9a06f6e (patch)
tree5fa7504774c0e71899bdd84ce54a6b64193ffdf5 /users/glittershark/xanthous/shell.nix
parent68779da59612dc467425a63f78fb34f5e53af8e0 (diff)
chore(xan): Install ghc-prof-flamegraph r/1057
Some things are slow, and it's time to profile them

Change-Id: I6a915db8bcc85adc7c3902a407cebb5a6f52d514
Reviewed-on: https://cl.tvl.fyi/c/depot/+/553
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to '')
-rw-r--r--users/glittershark/xanthous/shell.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/users/glittershark/xanthous/shell.nix b/users/glittershark/xanthous/shell.nix
index edd2fe4c08..4814966427 100644
--- a/users/glittershark/xanthous/shell.nix
+++ b/users/glittershark/xanthous/shell.nix
@@ -27,4 +27,7 @@ let
 
   inherit (pkgs.haskell.lib) addBuildTools;
 in
-(addBuildTools drv (with haskellPackages; [ cabal-install ])).env
+(addBuildTools drv (with haskellPackages; [
+  cabal-install
+  ghc-prof-flamegraph
+])).env