about summary refs log tree commit diff
path: root/users/glittershark/xanthous/pkg.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-06-29T00·33-0400
committerglittershark <grfn@gws.fyi>2020-06-29T00·38+0000
commit48cc610fa4681e4a423f47c5a9a19bf8ebe05821 (patch)
tree4a6f2e16636798f0ff714199a6793d485f3b5b01 /users/glittershark/xanthous/pkg.nix
parent93d1ab7a549143bb9f2e251409de3ac8282da828 (diff)
fix(xan): Build without nixpkgs in NIX_PATH r/1118
CI doesn't have a nixpkgs channel (obvs), and we want to be able to
build from the depot tree, so reorder some stuff so we never depend on
nixpkgs

Change-Id: I99b513a3d7bcd64b6d167335856651e0ca66e33b
Reviewed-on: https://cl.tvl.fyi/c/depot/+/734
Diffstat (limited to '')
-rw-r--r--users/glittershark/xanthous/pkg.nix5
1 files changed, 1 insertions, 4 deletions
diff --git a/users/glittershark/xanthous/pkg.nix b/users/glittershark/xanthous/pkg.nix
index dcf508fa54..91de68ea32 100644
--- a/users/glittershark/xanthous/pkg.nix
+++ b/users/glittershark/xanthous/pkg.nix
@@ -1,9 +1,6 @@
-{ nixpkgs ? import ./nixpkgs.nix {}
-,
-}:
+{ pkgs ? import ./nixpkgs.nix {} }:
 let
   inherit (builtins) filterSource elem not;
-  inherit (nixpkgs) pkgs;
   gitignoreSource = (import (pkgs.fetchFromGitHub {
     owner = "hercules-ci";
     repo = "gitignore";