about summary refs log tree commit diff
path: root/users/glittershark/xanthous/pkg.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-06-16T00·05+0100
committerVincent Ambo <mail@tazj.in>2020-06-16T00·05+0100
commit2edb963b97867b27f68efac8d05bf966077b0b01 (patch)
treec3bb279dfd4330e09a0af6ef4e84ff8a9a3bc7ad /users/glittershark/xanthous/pkg.nix
parent91f53f02d8479303910abfd3f3690d3ef27e6c4b (diff)
parent53b56744f4335c038724a1bcffc27a7eb8cf6a6d (diff)
Add 'users/glittershark/xanthous/' from commit '53b56744f4335c038724a1bcffc27a7eb8cf6a6d' r/978
git-subtree-dir: users/glittershark/xanthous
git-subtree-mainline: 91f53f02d8479303910abfd3f3690d3ef27e6c4b
git-subtree-split: 53b56744f4335c038724a1bcffc27a7eb8cf6a6d
Diffstat (limited to 'users/glittershark/xanthous/pkg.nix')
-rw-r--r--users/glittershark/xanthous/pkg.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/users/glittershark/xanthous/pkg.nix b/users/glittershark/xanthous/pkg.nix
new file mode 100644
index 0000000000..dcf508fa54
--- /dev/null
+++ b/users/glittershark/xanthous/pkg.nix
@@ -0,0 +1,19 @@
+{ nixpkgs ? import ./nixpkgs.nix {}
+,
+}:
+let
+  inherit (builtins) filterSource elem not;
+  inherit (nixpkgs) pkgs;
+  gitignoreSource = (import (pkgs.fetchFromGitHub {
+    owner = "hercules-ci";
+    repo = "gitignore";
+    rev = "f9e996052b5af4032fe6150bba4a6fe4f7b9d698";
+    sha256 = "0jrh5ghisaqdd0vldbywags20m2cxpkbbk5jjjmwaw0gr8nhsafv";
+    # date = 2019-09-18T15:15:15+02:00;
+  }) { inherit (pkgs) lib; }).gitignoreSource;
+in
+import (pkgs.haskellPackages.haskellSrc2nix {
+  name = "xanthous";
+  src = gitignoreSource ./.;
+  extraCabal2nixOptions = "--hpack";
+})