about summary refs log tree commit diff
path: root/users/glittershark/xanthous/haskell-overlay.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-06-29T00·33-0400
committerglittershark <grfn@gws.fyi>2020-06-29T00·38+0000
commit48cc610fa4681e4a423f47c5a9a19bf8ebe05821 (patch)
tree4a6f2e16636798f0ff714199a6793d485f3b5b01 /users/glittershark/xanthous/haskell-overlay.nix
parent93d1ab7a549143bb9f2e251409de3ac8282da828 (diff)
fix(xan): Build without nixpkgs in NIX_PATH r/1118
CI doesn't have a nixpkgs channel (obvs), and we want to be able to
build from the depot tree, so reorder some stuff so we never depend on
nixpkgs

Change-Id: I99b513a3d7bcd64b6d167335856651e0ca66e33b
Reviewed-on: https://cl.tvl.fyi/c/depot/+/734
Diffstat (limited to 'users/glittershark/xanthous/haskell-overlay.nix')
-rw-r--r--users/glittershark/xanthous/haskell-overlay.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/users/glittershark/xanthous/haskell-overlay.nix b/users/glittershark/xanthous/haskell-overlay.nix
index ad1200ef77..86a3514982 100644
--- a/users/glittershark/xanthous/haskell-overlay.nix
+++ b/users/glittershark/xanthous/haskell-overlay.nix
@@ -1,6 +1,5 @@
-{ nixpkgs ? import ./nixpkgs.nix {} }:
-let inherit (nixpkgs) pkgs;
-in self: super: with pkgs.haskell.lib; rec {
+{ pkgs ? import ./nixpkgs.nix {} }:
+self: super: with pkgs.haskell.lib; rec {
   generic-arbitrary = appendPatch
     super.generic-arbitrary
     [ ./build/generic-arbitrary-export-garbitrary.patch ];
@@ -22,7 +21,7 @@ in self: super: with pkgs.haskell.lib; rec {
 
   vinyl = overrideSrc (markUnbroken super.vinyl)
     rec {
-      src = nixpkgs.fetchzip {
+      src = pkgs.fetchzip {
         url = "mirror://hackage/vinyl-${version}/vinyl-${version}.tar.gz";
         sha256 = "190ffrmm76fh8fi9afkcda2vldf89y7dxj10434h28mbpq55kgsx";
       };
@@ -35,7 +34,7 @@ in self: super: with pkgs.haskell.lib; rec {
   ghc-prof-flamegraph = overrideCabal super.ghc-prof-flamegraph (oldAttrs: rec {
     version = "0.2.0.0";
 
-    src = nixpkgs.fetchFromGitHub {
+    src = pkgs.fetchFromGitHub {
       owner = "fpco";
       repo = "ghc-prof-flamegraph";
       rev = "8edd3b4806adeb25a4d55bed51c3afcc8e7a8e14";