about summary refs log tree commit diff
path: root/users/glittershark/xanthous/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-06-29T01·27-0400
committerglittershark <grfn@gws.fyi>2020-06-29T01·56+0000
commit8091da8f0f6efd365dddf4a09555ed49c093ea50 (patch)
tree0c79b385807ba80de21a9fd2f09ec5cbb57067bc /users/glittershark/xanthous/default.nix
parent0ecc9b4ed3e53698dc44332abd06c67a6f8ffdbb (diff)
feat(3p/haskellPackages): port in patches from xanthous r/1124
Add a few relatively uncontroversial patches to fix some broken packages
that I had developed for xanthous to the top-level third_party tree, so
they can be reused by other people in the monorepo

Change-Id: I68740477bda278c5dcc123080029ee4bd2cae37a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/740
Reviewed-by: Profpatsch <mail@profpatsch.de>
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'users/glittershark/xanthous/default.nix')
-rw-r--r--users/glittershark/xanthous/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/users/glittershark/xanthous/default.nix b/users/glittershark/xanthous/default.nix
index 4af535a34d..c4260fe258 100644
--- a/users/glittershark/xanthous/default.nix
+++ b/users/glittershark/xanthous/default.nix
@@ -16,6 +16,6 @@ let
   xanthous =
     (if failOnWarnings then pkgs.haskell.lib.failOnAllWarnings else id)
       ((pkgs.haskellPackages
-      .extend (import ./haskell-overlay.nix { inherit pkgs; })
+      # .extend (import ./haskell-overlay.nix { inherit pkgs; })
     ).callPackage (import ./pkg.nix { inherit pkgs; }) {}); in
 xanthous // { inherit hie; }