about summary refs log tree commit diff
path: root/users/glittershark/system/system/machines/yeren.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-11-29T23·59-0500
committerglittershark <grfn@gws.fyi>2020-11-30T00·03+0000
commitd4fb573cf76ebb1651bcce711bd4cba849a1404d (patch)
tree025969daf566ce5c15dadb0227cb0b297de51fb1 /users/glittershark/system/system/machines/yeren.nix
parent904cd3e6c040f7ac028c75f8a1fd7e2b1cb2b629 (diff)
feat(gs/system): Init yeren r/1962
My new work laptop, a dell XPS 13.

Change-Id: Ieab06622c9b280182025edfa63adf649e5fc70d8
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2205
Tested-by: BuildkiteCI
Reviewed-by: glittershark <grfn@gws.fyi>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Diffstat (limited to 'users/glittershark/system/system/machines/yeren.nix')
-rw-r--r--users/glittershark/system/system/machines/yeren.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/users/glittershark/system/system/machines/yeren.nix b/users/glittershark/system/system/machines/yeren.nix
new file mode 100644
index 0000000000..541da0969e
--- /dev/null
+++ b/users/glittershark/system/system/machines/yeren.nix
@@ -0,0 +1,46 @@
+{ modulesPath, config, lib, pkgs, ... }:
+
+{
+  imports = [
+    (modulesPath + "/installer/scan/not-detected.nix")
+    ../modules/common.nix
+    ../modules/reusable/battery.nix
+    ../modules/xserver.nix
+    ../modules/fonts.nix
+    ../modules/sound.nix
+  ];
+
+  networking.hostName = "yeren";
+
+  system.stateVersion = "21.03";
+
+  boot = {
+    initrd = {
+      availableKernelModules = [ "xhci_pci" "thunderbolt" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];
+      kernelModules = [ ];
+
+      luks.devices = {
+        "cryptroot".device = "/dev/disk/by-uuid/dcfbc22d-e0d2-411b-8dd3-96704d3aae2e";
+        "cryptswap".device = "/dev/disk/by-uuid/48b8a8fd-559c-4759-a617-56f221cfaaec";
+      };
+    };
+
+    kernelPackages = pkgs.linuxPackages_latest;
+    kernelModules = [ "kvm-intel" ];
+    extraModulePackages = [ ];
+  };
+
+  fileSystems = {
+    "/" = {
+      device = "/dev/mapper/cryptroot";
+      fsType = "btrfs";
+    };
+
+    "/boot" = {
+      device = "/dev/disk/by-uuid/53A9-248B";
+      fsType = "vfat";
+    };
+  };
+
+  swapDevices = [{ device = "/dev/mapper/cryptswap"; }];
+}