about summary refs log tree commit diff
path: root/users/glittershark/system/system/machines/roswell.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-12-14T17·44-0500
committerglittershark <grfn@gws.fyi>2020-12-14T18·18+0000
commitbcea9cd0b37b533f55f9b73286e7a8db2c33f858 (patch)
tree1f9b6b16691882a40ca3683a48e425977aa9262a /users/glittershark/system/system/machines/roswell.nix
parent3f9bd60d854535ce77aa0b1f6e5aba5a7d06cc93 (diff)
feat(gs/system): Init roswell r/2000
An ec2 node I'm using as a remote dev box

Change-Id: I7d81371ecdc11d6c1b5bc06d1b4f55de534d25ad
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2244
Tested-by: BuildkiteCI
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'users/glittershark/system/system/machines/roswell.nix')
-rw-r--r--users/glittershark/system/system/machines/roswell.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/users/glittershark/system/system/machines/roswell.nix b/users/glittershark/system/system/machines/roswell.nix
new file mode 100644
index 0000000000..c0ed2264a0
--- /dev/null
+++ b/users/glittershark/system/system/machines/roswell.nix
@@ -0,0 +1,17 @@
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+  imports = [
+    ../modules/common.nix
+    "${modulesPath}/installer/scan/not-detected.nix"
+    "${modulesPath}/virtualisation/amazon-image.nix"
+  ];
+
+  ec2.hvm = true;
+
+  networking.hostName = "roswell";
+
+  users.users.grfn.openssh.authorizedKeys.keys = [
+    config.depot.users.glittershark.keys.main
+  ];
+}