about summary refs log tree commit diff
path: root/users/glittershark/system/pkgs/notifymuch.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-08-28T14·25-0400
committerglittershark <grfn@gws.fyi>2020-08-28T21·24+0000
commita7cd92770d3d2f35ae04713fb5e245536a1a95e9 (patch)
tree757fea8bcf73331454db57bdf609f96f8ceb849b /users/glittershark/system/pkgs/notifymuch.nix
parentfb0528c5dada2d3af6152b37a46e505e6bb2ac94 (diff)
revert(glittershark): "Temporarily skip grfn's subtree" r/1728
This reverts commit 475d41f698415919093ca98f676ffcda218093ac. I'd like
my derivations back, please.

Changes necessary to get this working:

- Don't depend on `nixpkgs` being in the NIX_PATH for my website - it's
  not necessary anyway since emacs 27 is mainline now
- .skip-subtrees on things that shouldn't be evaluated anyway
- Get rid of system/pkgs, and move the one thing in there that *wasn't*
  already in third_party (alsi) to third_party
- Drop notifymuch for now - it's not working, and I'll probably get it
  landed in nixpkgs before I manage to get it working
- Add __readTree = true to my systems so they get built.
- explicitly disable ci for xanthous, which is failing to build and had
  been omitted previously

Change-Id: I20f5e81d6eb7ffe040091a08d75d0cb15304f707
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1864
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'users/glittershark/system/pkgs/notifymuch.nix')
-rw-r--r--users/glittershark/system/pkgs/notifymuch.nix55
1 files changed, 0 insertions, 55 deletions
diff --git a/users/glittershark/system/pkgs/notifymuch.nix b/users/glittershark/system/pkgs/notifymuch.nix
deleted file mode 100644
index 065bcddd07c6..000000000000
--- a/users/glittershark/system/pkgs/notifymuch.nix
+++ /dev/null
@@ -1,55 +0,0 @@
-{ stdenv
-, buildPythonApplication
-, isPy3k
-, fetchFromGitHub
-, notmuch
-, pygobject3
-, gobject-introspection
-, libnotify
-, wrapGAppsHook
-, gtk3
-}:
-
-buildPythonApplication rec {
-  pname = "notifymuch";
-  version = "0.1";
-  disabled = ! isPy3k;
-
-  src = fetchFromGitHub {
-    owner = "kspi";
-    repo = "notifymuch";
-    rev = "9d4aaf54599282ce80643b38195ff501120807f0";
-    sha256 = "1lssr7iv43mp5v6nzrfbqlfzx8jcc7m636wlfyhhnd8ydd39n6k4";
-  };
-
-  propagatedBuildInputs = [
-    notmuch
-    pygobject3
-    libnotify
-    gtk3
-  ];
-
-  nativeBuildInputs = [
-    gobject-introspection
-    wrapGAppsHook
-  ];
-
-  dontWrapGApps = true;
-
-  preFixup = ''
-    echo "wrapper args"
-    echo "''${makeWrapperArgs[@]}"
-    makeWrapperArgs+=("''${gappsWrapperArgs[@]}")
-    echo "wrapper args again"
-    echo "''${makeWrapperArgs[@]}"
-  '';
-
-  strictDeps = false;
-
-  meta = with stdenv.lib; {
-    description = "Display desktop notifications for unread mail in a notmuch database";
-    homepage = "https://github.com/kspi/notifymuch";
-    maintainers = with maintainers; [ glittershark ];
-    license = licenses.gpl3;
-  };
-}