about summary refs log tree commit diff
path: root/users/glittershark/system/pkgs/notifymuch.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-07-15T18·02-0400
committerglittershark <grfn@gws.fyi>2020-07-15T18·06+0000
commit1fd34a82cb03ba93f90ce58dd75d08039316e57e (patch)
tree7820e2570d8c4ff3a25d8e8747be570f8dc3b79f /users/glittershark/system/pkgs/notifymuch.nix
parent8c34a475671cc67216c9b7dbccc4cb493fd05227 (diff)
feat(gs/home): Add config for email notifications r/1301
This uses the notifymuch package pulled from
https://github.com/NixOS/nixpkgs/pull/92797 right now, but eventually I
would like to pull from a vendored version since there are some changes
I would like to make to how the notifications are rendered and it looks
like upstream is unmaintained.

Change-Id: I3d1d355a09171a33677f095aa068f2499d50b37b
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1177
Reviewed-by: glittershark <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--users/glittershark/system/pkgs/notifymuch.nix55
1 files changed, 55 insertions, 0 deletions
diff --git a/users/glittershark/system/pkgs/notifymuch.nix b/users/glittershark/system/pkgs/notifymuch.nix
new file mode 100644
index 0000000000..065bcddd07
--- /dev/null
+++ b/users/glittershark/system/pkgs/notifymuch.nix
@@ -0,0 +1,55 @@
+{ stdenv
+, buildPythonApplication
+, isPy3k
+, fetchFromGitHub
+, notmuch
+, pygobject3
+, gobject-introspection
+, libnotify
+, wrapGAppsHook
+, gtk3
+}:
+
+buildPythonApplication rec {
+  pname = "notifymuch";
+  version = "0.1";
+  disabled = ! isPy3k;
+
+  src = fetchFromGitHub {
+    owner = "kspi";
+    repo = "notifymuch";
+    rev = "9d4aaf54599282ce80643b38195ff501120807f0";
+    sha256 = "1lssr7iv43mp5v6nzrfbqlfzx8jcc7m636wlfyhhnd8ydd39n6k4";
+  };
+
+  propagatedBuildInputs = [
+    notmuch
+    pygobject3
+    libnotify
+    gtk3
+  ];
+
+  nativeBuildInputs = [
+    gobject-introspection
+    wrapGAppsHook
+  ];
+
+  dontWrapGApps = true;
+
+  preFixup = ''
+    echo "wrapper args"
+    echo "''${makeWrapperArgs[@]}"
+    makeWrapperArgs+=("''${gappsWrapperArgs[@]}")
+    echo "wrapper args again"
+    echo "''${makeWrapperArgs[@]}"
+  '';
+
+  strictDeps = false;
+
+  meta = with stdenv.lib; {
+    description = "Display desktop notifications for unread mail in a notmuch database";
+    homepage = "https://github.com/kspi/notifymuch";
+    maintainers = with maintainers; [ glittershark ];
+    license = licenses.gpl3;
+  };
+}