about summary refs log tree commit diff
path: root/users/glittershark/system/pkgs/clang-tools
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2020-06-16T00·02+0100
committerVincent Ambo <mail@tazj.in>2020-06-16T00·02+0100
commit81564185e951f69d490be8f5ad76e8ea642b5dde (patch)
treec27cd8a5bb922f710ff7da4b2942d2db09a95376 /users/glittershark/system/pkgs/clang-tools
parent85d82a9dc262bffa87423f595f7e957c42713798 (diff)
parent3b174300ae60f63f50427cde3bfd680fd3043c3a (diff)
Add 'users/glittershark/system/' from commit '3b174300ae60f63f50427cde3bfd680fd3043c3a' r/975
git-subtree-dir: users/glittershark/system
git-subtree-mainline: 85d82a9dc262bffa87423f595f7e957c42713798
git-subtree-split: 3b174300ae60f63f50427cde3bfd680fd3043c3a
Diffstat (limited to 'users/glittershark/system/pkgs/clang-tools')
-rw-r--r--users/glittershark/system/pkgs/clang-tools/default.nix24
-rw-r--r--users/glittershark/system/pkgs/clang-tools/wrapper20
2 files changed, 44 insertions, 0 deletions
diff --git a/users/glittershark/system/pkgs/clang-tools/default.nix b/users/glittershark/system/pkgs/clang-tools/default.nix
new file mode 100644
index 000000000000..7c1009665eb6
--- /dev/null
+++ b/users/glittershark/system/pkgs/clang-tools/default.nix
@@ -0,0 +1,24 @@
+{ pkgs }:
+with pkgs;
+
+runCommand "clang-tools" {} ''
+  mkdir -p $out/bin
+  export libc_includes="${stdenv.lib.getDev stdenv.cc.libc}/include"
+  export libcpp_includes="${llvmPackages.libcxx}/include/c++/v1"
+
+  export clang=${llvmPackages.clang-unwrapped}
+
+  echo $clang
+
+  substituteAll ${./wrapper} $out/bin/clangd
+  chmod +x $out/bin/clangd
+  for tool in \
+    clang-apply-replacements \
+    clang-check \
+    clang-format \
+    clang-rename \
+    clang-tidy
+  do
+    ln -s $out/bin/clangd $out/bin/$tool
+  done
+''
diff --git a/users/glittershark/system/pkgs/clang-tools/wrapper b/users/glittershark/system/pkgs/clang-tools/wrapper
new file mode 100644
index 000000000000..949a4243e009
--- /dev/null
+++ b/users/glittershark/system/pkgs/clang-tools/wrapper
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+buildcpath() {
+  local path
+  while (( $# )); do
+    case $1 in
+        -isystem)
+            shift
+            path=$path${path:+':'}$1
+    esac
+    shift
+  done
+  echo $path
+}
+
+export CPATH=${CPATH}${CPATH:+':'}$(buildcpath ${NIX_CFLAGS_COMPILE})
+export CPATH=${CPATH}${CPATH:+':'}@libc_includes@
+export CPLUS_INCLUDE_PATH=@libcpp_includes@${CPATH:+':'}${CPATH}
+
+exec -a "$0" @clang@/bin/$(basename $0) "$@"