about summary refs log tree commit diff
path: root/users/glittershark/system/pkgs/alsi/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-08-28T14·25-0400
committerglittershark <grfn@gws.fyi>2020-08-28T21·24+0000
commita7cd92770d3d2f35ae04713fb5e245536a1a95e9 (patch)
tree757fea8bcf73331454db57bdf609f96f8ceb849b /users/glittershark/system/pkgs/alsi/default.nix
parentfb0528c5dada2d3af6152b37a46e505e6bb2ac94 (diff)
revert(glittershark): "Temporarily skip grfn's subtree" r/1728
This reverts commit 475d41f698415919093ca98f676ffcda218093ac. I'd like
my derivations back, please.

Changes necessary to get this working:

- Don't depend on `nixpkgs` being in the NIX_PATH for my website - it's
  not necessary anyway since emacs 27 is mainline now
- .skip-subtrees on things that shouldn't be evaluated anyway
- Get rid of system/pkgs, and move the one thing in there that *wasn't*
  already in third_party (alsi) to third_party
- Drop notifymuch for now - it's not working, and I'll probably get it
  landed in nixpkgs before I manage to get it working
- Add __readTree = true to my systems so they get built.
- explicitly disable ci for xanthous, which is failing to build and had
  been omitted previously

Change-Id: I20f5e81d6eb7ffe040091a08d75d0cb15304f707
Reviewed-on: https://cl.tvl.fyi/c/depot/+/1864
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'users/glittershark/system/pkgs/alsi/default.nix')
-rw-r--r--users/glittershark/system/pkgs/alsi/default.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/users/glittershark/system/pkgs/alsi/default.nix b/users/glittershark/system/pkgs/alsi/default.nix
deleted file mode 100644
index d4da8ff38ef7..000000000000
--- a/users/glittershark/system/pkgs/alsi/default.nix
+++ /dev/null
@@ -1,22 +0,0 @@
-{ perl, stdenv, fetchFromGitHub }:
-stdenv.mkDerivation {
-  name = "alsi";
-  pname = "alsi";
-  version = "0.4.8";
-
-  src = fetchFromGitHub {
-    owner = "trizen";
-    repo = "alsi";
-    rev = "fe2a925caad38d4cc7afe10d74ba60c5db09ee66";
-    sha256 = "060xlalfclrda5f1h3svj4v2gr19mdrsc62vrg7hgii0f3lib7j5";
-  };
-
-  buildInputs = [
-    (perl.withPackages (ps: with ps; [ DataDump ]))
-  ];
-
-  installPhase = ''
-    mkdir -p $out/bin
-    cp alsi $out/bin/alsi
-  '';
-}