about summary refs log tree commit diff
path: root/users/glittershark/system/home/modules/development/rust.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-11-29T23·54-0500
committerglittershark <grfn@gws.fyi>2020-11-30T00·04+0000
commit1caac9b637c75c0e1ddb49fe1aba97cc2d879d83 (patch)
tree2a91b19d8cc56458515b280bfb3e5cb837bb55ca /users/glittershark/system/home/modules/development/rust.nix
parenta8a9e88d68f79337249b9b5bb4f9f8f1d4d2cc56 (diff)
feat(gs/home): Add rust development tools r/1964
rustup and rust-analyzer for now, but this will likely also have shell
aliases and the like

Change-Id: I7838e537a72600410205e018a0c86be1493a9ffe
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2207
Reviewed-by: glittershark <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--users/glittershark/system/home/modules/development/rust.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/users/glittershark/system/home/modules/development/rust.nix b/users/glittershark/system/home/modules/development/rust.nix
new file mode 100644
index 0000000000..17bda9c746
--- /dev/null
+++ b/users/glittershark/system/home/modules/development/rust.nix
@@ -0,0 +1,8 @@
+{ config, lib, pkgs, ... }:
+
+{
+  home.packages = with pkgs; [
+    rustup
+    rust-analyzer
+  ];
+}