about summary refs log tree commit diff
path: root/users/glittershark/system/home/machines/roswell.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-12-14T17·44-0500
committerglittershark <grfn@gws.fyi>2020-12-14T18·18+0000
commitbcea9cd0b37b533f55f9b73286e7a8db2c33f858 (patch)
tree1f9b6b16691882a40ca3683a48e425977aa9262a /users/glittershark/system/home/machines/roswell.nix
parent3f9bd60d854535ce77aa0b1f6e5aba5a7d06cc93 (diff)
feat(gs/system): Init roswell r/2000
An ec2 node I'm using as a remote dev box

Change-Id: I7d81371ecdc11d6c1b5bc06d1b4f55de534d25ad
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2244
Tested-by: BuildkiteCI
Reviewed-by: glittershark <grfn@gws.fyi>
Diffstat (limited to 'users/glittershark/system/home/machines/roswell.nix')
-rw-r--r--users/glittershark/system/home/machines/roswell.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/users/glittershark/system/home/machines/roswell.nix b/users/glittershark/system/home/machines/roswell.nix
new file mode 100644
index 0000000000..1b1bbf29c6
--- /dev/null
+++ b/users/glittershark/system/home/machines/roswell.nix
@@ -0,0 +1,57 @@
+{ pkgs, lib, config, ... }:
+
+let
+  laptopKeyboardId = "5";
+in
+
+{
+  imports = [
+    ../platforms/linux.nix
+    ../modules/shell.nix
+    ../modules/development.nix
+    ../modules/emacs.nix
+    ../modules/vim.nix
+  ];
+
+  home.packages = with pkgs; [
+    # System utilities
+    bat
+    htop
+    killall
+    bind
+    zip unzip
+    tree
+    ncat
+    bc
+    pv
+
+    # Security
+    gnupg
+    keybase
+    openssl
+
+    # Nix things
+    nixfmt
+    nix-prefetch-github
+    nix-review
+    cachix
+  ];
+
+
+  nixpkgs.config.allowUnfree = true;
+
+  programs.password-store.enable = true;
+
+  programs.home-manager.enable = true;
+  home.stateVersion = "20.03";
+
+  xsession.enable = lib.mkForce false;
+
+  services.lorri.enable = true;
+
+  programs.direnv = {
+    enable = true;
+    enableBashIntegration = true;
+    enableZshIntegration = true;
+  };
+}