about summary refs log tree commit diff
path: root/users/glittershark/gws.fyi/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2021-03-28T23·51-0400
committerglittershark <grfn@gws.fyi>2021-03-29T00·00+0000
commit8d094be9ce50701b7ea005df74af6bba99a1547a (patch)
tree1c9a8e1cd2b3bc11422a5f89adbdf22825377c8f /users/glittershark/gws.fyi/default.nix
parentc3f35caefa65b117f2590108f2fe2ecc2750721c (diff)
feat(gws.fyi): Add some very light CSS r/2358
web-brutalism is so 3 years ago, bro

but seriously, I'd like to start putting some actual stuff here, so
let's make it look halfway-decent.

Change-Id: Ic78d725b3755c2307c7ea155af8d0f90e287830c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2697
Reviewed-by: glittershark <grfn@gws.fyi>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/glittershark/gws.fyi/default.nix')
-rw-r--r--users/glittershark/gws.fyi/default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/users/glittershark/gws.fyi/default.nix b/users/glittershark/gws.fyi/default.nix
index 6ec1262f67..38d64cef57 100644
--- a/users/glittershark/gws.fyi/default.nix
+++ b/users/glittershark/gws.fyi/default.nix
@@ -5,9 +5,17 @@ let
   resume = import ../resume args;
   bucket = "s3://gws.fyi";
   distributionID = "E2ST43JNBH8C64";
+
+  css = runCommand "main.css" {
+    buildInputs = [ pkgs.minify ];
+  } ''
+    minify --type css < ${./main.css} > $out
+  '';
+
   website =
     runCommand "gws.fyi" { } ''
       mkdir -p $out
+      cp ${css} $out/main.css
       cp ${site.index} $out/index.html
       cp ${resume} $out/resume.pdf
     '';