about summary refs log tree commit diff
path: root/users/flokli/presentations/2023-09-13-asg-tvix-store/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-10-13T14·01+0200
committerflokli <flokli@flokli.de>2023-10-16T11·49+0000
commit8b09ae54b1d635e77c394dd965915479283489a2 (patch)
tree8b2b1c6580d40acf185296ef182f66165a17410a /users/flokli/presentations/2023-09-13-asg-tvix-store/default.nix
parentb8ef3e52637fc783ec03b209ce2f4f4a25152a27 (diff)
feat(users/flokli): add ASG Lightning talk presentation r/6830
This adds the materials for the lightning talk held at All Systems Go
Conference 2023, Berlin.

Talk lives at https://media.ccc.de/v/all-systems-go-2023-245-tvix-store

Change-Id: I114b1aec9f1953c148dd29ca88888c16b9fc655d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9751
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/flokli/presentations/2023-09-13-asg-tvix-store/default.nix')
-rw-r--r--users/flokli/presentations/2023-09-13-asg-tvix-store/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/users/flokli/presentations/2023-09-13-asg-tvix-store/default.nix b/users/flokli/presentations/2023-09-13-asg-tvix-store/default.nix
new file mode 100644
index 000000000000..840f21de8103
--- /dev/null
+++ b/users/flokli/presentations/2023-09-13-asg-tvix-store/default.nix
@@ -0,0 +1,32 @@
+{ depot, pkgs, ... }:
+
+let
+  inherit (pkgs)
+    fontconfig qrencode runCommand stdenv;
+  mkQr = url: runCommand "qrcode.png" { } ''
+    ${qrencode}/bin/qrencode -o $out -t SVG -s 5 \
+      --background=fafafa \
+      --foreground=000000 \
+      ${url}
+  '';
+in
+stdenv.mkDerivation {
+  name = "2023-asg-tvix-store";
+  src = ./.;
+
+  FONTCONFIG_FILE = pkgs.makeFontsConf {
+    fontDirectories = with pkgs; [ jetbrains-mono fira fira-code fira-mono lato ];
+  };
+
+  nativeBuildInputs = [ pkgs.reveal-md pkgs.graphviz ];
+
+  buildPhase = ''
+    cp ${depot.tvix.logo}/logo.png tvix-logo.png
+    cp ${mkQr "https://flokli.de"} qrcode-flokli.svg
+    cp ${mkQr "https://tvix.dev"} qrcode-tvix.svg
+
+    mkdir -p $out
+    cp tvix-store-graph-blob-directory.svg $out/
+    reveal-md --static $out presentation.md
+  '';
+}