about summary refs log tree commit diff
path: root/users/flokli/nixos/archeology/hardware-configuration.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2023-10-29T16·28+0200
committerflokli <flokli@flokli.de>2023-10-29T16·31+0000
commit48b6242313f9ecbc49a9e768f59a966348f6446c (patch)
tree19e4f51e7bd4f049f9e412c8528df640059f85fd /users/flokli/nixos/archeology/hardware-configuration.nix
parent12fb5004d9033ca50579deddcdb5ee0160a296fd (diff)
feat(users/flokli/nixos): init archeology r/6903
Change-Id: Ic31cb8030179ff37b1cc3d3d9241e2582cfe3e5e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9833
Tested-by: BuildkiteCI
Reviewed-by: edef <edef@edef.eu>
Autosubmit: flokli <flokli@flokli.de>
Diffstat (limited to 'users/flokli/nixos/archeology/hardware-configuration.nix')
-rw-r--r--users/flokli/nixos/archeology/hardware-configuration.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/users/flokli/nixos/archeology/hardware-configuration.nix b/users/flokli/nixos/archeology/hardware-configuration.nix
new file mode 100644
index 000000000000..8410df79d205
--- /dev/null
+++ b/users/flokli/nixos/archeology/hardware-configuration.nix
@@ -0,0 +1,36 @@
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+  imports =
+    [
+      (modulesPath + "/profiles/qemu-guest.nix")
+    ];
+
+  boot.initrd.availableKernelModules = [ "ahci" "xhci_pci" "virtio_pci" "sr_mod" "virtio_blk" ];
+  boot.initrd.kernelModules = [ ];
+  boot.kernelModules = [ "kvm-amd" ];
+  boot.extraModulePackages = [ ];
+
+  fileSystems."/" =
+    {
+      device = "/dev/disk/by-partlabel/root";
+      fsType = "xfs";
+    };
+
+  fileSystems."/boot" =
+    {
+      device = "/dev/disk/by-partlabel/boot";
+      fsType = "vfat";
+    };
+
+  swapDevices = [ ];
+
+  # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
+  # (the default) this is the recommended approach. When using systemd-networkd it's
+  # still possible to use this option, but it's recommended to use it in conjunction
+  # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
+  networking.useDHCP = lib.mkDefault true;
+  # networking.interfaces.enp1s0.useDHCP = lib.mkDefault true;
+
+  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+}