about summary refs log tree commit diff
path: root/users/flokli/ipu6-softisp/default.nix
diff options
context:
space:
mode:
authorAspen Smith <root@gws.fyi>2024-07-28T16·58-0400
committerclbot <clbot@tvl.fyi>2024-08-01T10·06+0000
commit756539a59687f9abc9fef5fce50b5590c35a242f (patch)
tree06bd57732c359bb5b366b225043b59c6dd2f2ad9 /users/flokli/ipu6-softisp/default.nix
parentbdf82698592acc3f27fa7a9aa612ea1ad7970437 (diff)
chore(3p/sources): Bump channels & overlays (2024-07-28) r/8435
* Treewide: re-run depotfmt

* //third_party/nixpkgs:html5validator: build with Python 3.11,
  dependency openstackdocstheme doesn't support 3.12

* //users/sterni/machines/ingeborg: adapt to poorly handled fcgiwrap
  module API change: https://github.com/NixOS/nixpkgs/pull/318599

* //tvix/*-go: regenerate protobuf files

* //third_party/nixpkgs:treefmt: Remove patch for merged pull request

* //users/flokli/ipu6-softisp: rebase, drop upstreamed kernel patches

Change-Id: Ie4e0df007c287e8cd6207683a9a25838aa5bd39a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11971
Autosubmit: sterni <sternenseemann@systemli.org>
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: flokli <flokli@flokli.de>
Reviewed-by: aspen <root@gws.fyi>
Tested-by: BuildkiteCI
Reviewed-by: tazjin <tazjin@tvl.su>
Reviewed-by: Ilan Joselevich <personal@ilanjoselevich.com>
Diffstat (limited to 'users/flokli/ipu6-softisp/default.nix')
-rw-r--r--users/flokli/ipu6-softisp/default.nix11
1 files changed, 7 insertions, 4 deletions
diff --git a/users/flokli/ipu6-softisp/default.nix b/users/flokli/ipu6-softisp/default.nix
index 66a2f04a5133..ab129d1bc85e 100644
--- a/users/flokli/ipu6-softisp/default.nix
+++ b/users/flokli/ipu6-softisp/default.nix
@@ -11,8 +11,8 @@
 let
   systemFor = sys: (depot.ops.nixos.nixosFor sys).system;
 in
-depot.nix.readTree.drvTargets rec {
-  testSystem = systemFor ({ modulesPath, pkgs, ... }: {
+(depot.nix.readTree.drvTargets rec {
+  testSystem = (systemFor ({ modulesPath, pkgs, ... }: {
     imports = [
       # Import the module, this is something a user would do in their config.
       ./config.nix
@@ -39,7 +39,10 @@ depot.nix.readTree.drvTargets rec {
 
     # Shut off the warning.
     system.stateVersion = "24.05";
-  });
+  })) // {
+    # 2024-07-28 aspen: The patches no longer cleanly apply on upstream
+    meta.broken = true;
+  };
 
   # Make sure the firmware requested by the driver is present in our firmware.
   # We do have a .zst suffix here, but that's fine, since request_firmware does
@@ -54,4 +57,4 @@ depot.nix.readTree.drvTargets rec {
     # all good, succeed build
     touch $out
   '';
-}
+})