about summary refs log tree commit diff
path: root/users/flokli/ipu6-softisp/config.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-02-13T10·49+0200
committerclbot <clbot@tvl.fyi>2024-02-13T15·37+0000
commit41cd3c44d2f76a0df0e279609c17ef62e7e622f4 (patch)
tree21f631381e86af0ebe9b8ca2703f4a4e2fe0ff7a /users/flokli/ipu6-softisp/config.nix
parent28173ca4b92d5bb723fe77ae217bcf4f3bb6ce0d (diff)
chore(users/flokli/ipu6-softisp): inline kernel patches r/7504
"media: ov2740: Fix hts value" got backported into linux-stable:

```
commit c5883a8a3676b94fe7cefde97c8eec50bb879eb2
Author: Hans de Goede <hdegoede@redhat.com>
Date:   Mon Dec 4 13:39:42 2023 +0100

    media: ov2740: Fix hts value

    [ Upstream commit 3735228bbe3511f844e03dfcc4003fadb59dde23 ]

    HTS must be more then width, so the 1080 value clearly is wrong,
    this is then corrected with some weird math dividing clocks in
    to_pixels_per_line() which results in the hts getting multiplied by 2,
    resulting in 2160.

    Instead just directly set hts to the correct value of 2160 and
    drop to_pixels_per_line().

    Signed-off-by: Hans de Goede <hdegoede@redhat.com>
    Signed-off-by: Sakari Ailus <sakari.ailus@linux.intel.com>
    Signed-off-by: Hans Verkuil <hverkuil-cisco@xs4all.nl>
    Signed-off-by: Sasha Levin <sashal@kernel.org>
```

So drop that patch from the list of kernel patches to apply (and vendor
in the patches).

Change-Id: I314ccb524d156c0f445ed923ce0600f27b8cc699
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10813
Tested-by: BuildkiteCI
Autosubmit: flokli <flokli@flokli.de>
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'users/flokli/ipu6-softisp/config.nix')
-rw-r--r--users/flokli/ipu6-softisp/config.nix5
1 files changed, 1 insertions, 4 deletions
diff --git a/users/flokli/ipu6-softisp/config.nix b/users/flokli/ipu6-softisp/config.nix
index 9232d5bc9ee5..10244f91a823 100644
--- a/users/flokli/ipu6-softisp/config.nix
+++ b/users/flokli/ipu6-softisp/config.nix
@@ -72,10 +72,7 @@ in
 
   boot.kernelPatches = [{
     name = "linux-kernel-test.patch";
-    patch = pkgs.fetchurl {
-      url = "https://copr-dist-git.fedorainfracloud.org/cgit/jwrdegoede/ipu6-softisp/kernel.git/plain/linux-kernel-test.patch?h=f39&id=0ed76891b2fc08579d08bedb9294a41840007299";
-      hash = "sha256-8hKP4nltGlkzr8iOgsIUT9Tt5i+x4kdLmw/+lFeNoGQ=";
-    };
+    patch = ./kernel/softisp.patch;
     extraStructuredConfig = {
       # needed for /dev/dma_heap
       DMABUF_HEAPS_CMA = lib.kernel.yes;