about summary refs log tree commit diff
path: root/users/edef/narinfo2parquet/Cargo.toml
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2024-10-12T23·00+0300
committerclbot <clbot@tvl.fyi>2024-10-12T23·17+0000
commitcb032b250e7b46ebc28038c8efb48f6a9c0ac75b (patch)
tree1a49250019a952e7ec1e0bc65f4213596c4f2992 /users/edef/narinfo2parquet/Cargo.toml
parentbb34210a6457b1d4d433531d5788c4e819f3eb11 (diff)
chore(tvix/tools): move narinfo2parquet to //users/edef r/8801
This is not a core Tvix tool, it's a tool that uses a Tvix component.

Change-Id: I81d2b2374da23489df0097dcabb8295c82652fc1
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12606
Reviewed-by: edef <edef@edef.eu>
Tested-by: BuildkiteCI
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to 'users/edef/narinfo2parquet/Cargo.toml')
-rw-r--r--users/edef/narinfo2parquet/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/users/edef/narinfo2parquet/Cargo.toml b/users/edef/narinfo2parquet/Cargo.toml
new file mode 100644
index 000000000000..40d721d28cef
--- /dev/null
+++ b/users/edef/narinfo2parquet/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "narinfo2parquet"
+version = "0.1.0"
+edition = "2021"
+
+# We can't join the //tvix workspace, because that locks zstd
+# at an ancient version, which is incompatible with polars
+[workspace]
+members = ["."]
+
+[dependencies]
+anyhow = { version = "1.0.75", features = ["backtrace"] }
+jemallocator = "0.5.4"
+nix-compat = { version = "0.1.0", path = "../../../tvix/nix-compat" }
+tempfile-fast = "0.3.4"
+zstd = "0.13.0"
+
+[dependencies.polars]
+version = "0.36.2"
+default-features = false
+features = [
+    "parquet",
+    "polars-io",
+    "dtype-categorical"
+]