about summary refs log tree commit diff
path: root/users/edef/narinfo2parquet/Cargo.toml
diff options
context:
space:
mode:
authorVova Kryachko <v.kryachko@gmail.com>2024-11-08T15·44-0500
committerVladimir Kryachko <v.kryachko@gmail.com>2024-11-12T02·15+0000
commitb564ed9d43f17c620439815b86d2940be197bd47 (patch)
treea828f081e0b9f3568366534b800c12d88d5cfff7 /users/edef/narinfo2parquet/Cargo.toml
parent72bc4e0270891d72213989096ff1180adc07a578 (diff)
feat(nix-daemon): Implement client handler. r/8907
This change includes only the basic nix handshake protocol handling and
sets up a client session. The only supported operation at this point is
SetOptions.

Additional operations will be implemented in subsequent cls.

Change-Id: I3eccd9e0ceb270c3865929543c702f1491768852
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12743
Autosubmit: Vladimir Kryachko <v.kryachko@gmail.com>
Tested-by: BuildkiteCI
Reviewed-by: flokli <flokli@flokli.de>
Reviewed-by: edef <edef@edef.eu>
Reviewed-by: Brian Olsen <me@griff.name>
Diffstat (limited to 'users/edef/narinfo2parquet/Cargo.toml')
-rw-r--r--users/edef/narinfo2parquet/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/users/edef/narinfo2parquet/Cargo.toml b/users/edef/narinfo2parquet/Cargo.toml
index 40d721d28cef..5a8c9bdbfa15 100644
--- a/users/edef/narinfo2parquet/Cargo.toml
+++ b/users/edef/narinfo2parquet/Cargo.toml
@@ -15,6 +15,9 @@ nix-compat = { version = "0.1.0", path = "../../../tvix/nix-compat" }
 tempfile-fast = "0.3.4"
 zstd = "0.13.0"
 
+# See https://github.com/pola-rs/polars/issues/19157
+hashbrown = { version = "0.14.5", features = ["raw"] }
+
 [dependencies.polars]
 version = "0.36.2"
 default-features = false