about summary refs log tree commit diff
path: root/users/aspen/system/system/modules/common.nix
diff options
context:
space:
mode:
authorAspen Smith <root@gws.fyi>2024-03-31T18·11-0400
committerclbot <clbot@tvl.fyi>2024-03-31T18·33+0000
commit1cebb775f1b8a5ca9d149c23df453a5f56f95fb8 (patch)
treed55dcce9ce4bcf0e7fe8fdc846e3c5a2fca6b9bc /users/aspen/system/system/modules/common.nix
parent55ab8b1e6a0d6fad331cc7b6c748ff30a856c385 (diff)
feat(aspen/system): Switch linux user login to aspen r/7813
Change-Id: I10369a20db3f1be92caf0bace94e8beb6af1dbaa
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11302
Tested-by: BuildkiteCI
Autosubmit: aspen <root@gws.fyi>
Reviewed-by: aspen <root@gws.fyi>
Diffstat (limited to 'users/aspen/system/system/modules/common.nix')
-rw-r--r--users/aspen/system/system/modules/common.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/users/aspen/system/system/modules/common.nix b/users/aspen/system/system/modules/common.nix
index 17140317f5b3..3eaeb2efc614 100644
--- a/users/aspen/system/system/modules/common.nix
+++ b/users/aspen/system/system/modules/common.nix
@@ -49,7 +49,7 @@ with lib;
     settings = { X11Forwarding = true; };
   };
 
-  users.users.grfn.openssh.authorizedKeys.keys =
+  users.users.aspen.openssh.authorizedKeys.keys =
     [ depot.users.aspen.keys.main ];
 
   programs.ssh.startAgent = true;
@@ -59,7 +59,7 @@ with lib;
   users.mutableUsers = true;
   programs.zsh.enable = true;
   environment.pathsToLink = [ "/share/zsh" ];
-  users.users.grfn = {
+  users.users.aspen = {
     isNormalUser = true;
     initialPassword = "password";
     extraGroups = [
@@ -71,7 +71,7 @@ with lib;
   };
 
   nix = {
-    settings.trusted-users = [ "grfn" ];
+    settings.trusted-users = [ "aspen" ];
     distributedBuilds = true;
 
     gc = {