about summary refs log tree commit diff
path: root/users/Profpatsch/writers/tests.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2021-01-01T17·55+0100
committerProfpatsch <mail@profpatsch.de>2021-01-03T16·12+0000
commit533e365c12b5097005626317171b789406c1780f (patch)
tree03e403ce923c23effee3bd26723be55a48dcd02e /users/Profpatsch/writers/tests.nix
parent4af195c5f294699340e349e936f994813a7112e4 (diff)
feat(users/Profpatsch): add python3Lib writer r/2051
Smol writer to create a python lib directly from a nix string.
The resulting library can be consumed by the writePython3 writer.

Change-Id: Id3d793564d230b38a08f65140bda4287285e1a72
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2310
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to '')
-rw-r--r--users/Profpatsch/writers/tests.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/users/Profpatsch/writers/tests.nix b/users/Profpatsch/writers/tests.nix
new file mode 100644
index 0000000000..4cae230e0e
--- /dev/null
+++ b/users/Profpatsch/writers/tests.nix
@@ -0,0 +1,22 @@
+{ depot, pkgs, python3Lib }:
+
+let
+  testLib = python3Lib {
+    name = "test_lib";
+  } ''
+    def test():
+      return "test"
+  '';
+
+  pythonWithLib = pkgs.writers.writePython3 "python-with-lib" {
+    libraries = [ testLib ];
+  } ''
+    import test_lib
+
+    assert(test_lib.test() == "test")
+  '';
+
+in {
+  inherit
+    pythonWithLib;
+}