about summary refs log tree commit diff
path: root/users/Profpatsch/sync-abfall-ics-aichach-friedberg/default.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2022-06-19T13·12+0200
committerProfpatsch <mail@profpatsch.de>2022-06-19T13·29+0000
commit7c0874c2282298aec8ee3cc9c2789223a718f0d8 (patch)
tree92b5b0c07a621d6c4ff22dcaa9c757f65652c080 /users/Profpatsch/sync-abfall-ics-aichach-friedberg/default.nix
parent3c3713c69f9a7fb0c14ef463ab520de7f601e1e9 (diff)
feat(users/Profpatsch/sync-abfall): caldav vdirsyncer config gen r/4248
Gonna have to generate some vdirsyncer config, reusing the toIni
stuff, nice.

Change-Id: I036ce9990f70d3b035e47151f336d0d3971f2c91
Reviewed-on: https://cl.tvl.fyi/c/depot/+/5888
Reviewed-by: Profpatsch <mail@profpatsch.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/Profpatsch/sync-abfall-ics-aichach-friedberg/default.nix')
-rw-r--r--users/Profpatsch/sync-abfall-ics-aichach-friedberg/default.nix19
1 files changed, 18 insertions, 1 deletions
diff --git a/users/Profpatsch/sync-abfall-ics-aichach-friedberg/default.nix b/users/Profpatsch/sync-abfall-ics-aichach-friedberg/default.nix
index 9c25972783..739274cb6f 100644
--- a/users/Profpatsch/sync-abfall-ics-aichach-friedberg/default.nix
+++ b/users/Profpatsch/sync-abfall-ics-aichach-friedberg/default.nix
@@ -10,5 +10,22 @@ let
       ]);
     } ./sync-ics-to-dir.py;
 
+  config =
+    depot.users.Profpatsch.importDhall.importDhall
+      {
+        root = ./..;
+        files = [
+          "sync-abfall-ics-aichach-friedberg/ics-to-caldav.dhall"
+          "dhall/lib.dhall"
+          "ini/ini.dhall"
+        ];
+        main = "sync-abfall-ics-aichach-friedberg/ics-to-caldav.dhall";
+        deps = [
+        ];
+      }
+      depot.users.Profpatsch.ini.externs;
+
+
+
 in
-sync-to-dir
+{ inherit config; }