about summary refs log tree commit diff
path: root/users/Profpatsch/shell.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2024-03-17T01·04+0100
committerclbot <clbot@tvl.fyi>2024-03-17T01·21+0000
commitefa5fe1239263ad49cbcdb0f0039e93b55686f36 (patch)
treec3e13aa43d0b2c6630059695d6937bd74cbdb254 /users/Profpatsch/shell.nix
parent8ca42dc0cd9c9bf462da8b167eb406a65bc83647 (diff)
feat(users/Profpatsch/whatcd-resolver): add services & readme r/7714
Gives a story for running both jaeger and the reverse proxy, and the
program proper.

`postgres` is still run from the client.

Adds a little readme.

Change-Id: I11185028541c0214e152fd76c9c72b7e2eb11122
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11171
Tested-by: BuildkiteCI
Autosubmit: Profpatsch <mail@profpatsch.de>
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'users/Profpatsch/shell.nix')
-rw-r--r--users/Profpatsch/shell.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/users/Profpatsch/shell.nix b/users/Profpatsch/shell.nix
index f749c2e3439a..e04d7f195f82 100644
--- a/users/Profpatsch/shell.nix
+++ b/users/Profpatsch/shell.nix
@@ -4,6 +4,7 @@ let root = (import ../../. { }); in
 { pkgs ? root.third_party.nixpkgs, depot ? root, ... }:
 
 pkgs.mkShell {
+
   buildInputs = [
     pkgs.sqlite-interactive
     pkgs.sqlite-utils
@@ -63,8 +64,18 @@ pkgs.mkShell {
     pkgs.postgresql_14
     pkgs.nodejs
     pkgs.ninja
+    pkgs.s6
+    pkgs.caddy
+
+    (depot.nix.binify {
+      name = "nix-run";
+      exe = depot.users.Profpatsch.nix-tools.nix-run;
+    })
   ];
 
+  DEPOT_ROOT = toString ./../..;
+  PROFPATSCH_ROOT = toString ./.;
+
   WHATCD_RESOLVER_TOOLS = pkgs.linkFarm "whatcd-resolver-tools" [
     {
       name = "pg_format";