about summary refs log tree commit diff
path: root/users/Profpatsch/shell.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2023-01-08T22·41+0100
committerProfpatsch <mail@profpatsch.de>2023-01-08T23·10+0000
commitcd40585ea4481625ed8c198ee56ce2e453a1cd9c (patch)
treed01e057271c64df72624e022b67265141b4d13e5 /users/Profpatsch/shell.nix
parent8cdefc5b253109d319267b68f0f45c0d3f021d17 (diff)
feat(users/Profpatsch/netencode): Add initial Haskell parser r/5632
A simple categorical parser that does not implement Monad, and does
not contain an `m` and some rudementary error message handling.

In the future I’d probably want to wrap everything in an additional
`m`, so that subparsers can somehow use `Selective` to throw errors
from within `m` that contain the parsing context if at all possible.
Hard to do without Monad, I have to say. Not even stuff like `StateT`
works without the inner `m` implementing `Monad`.

Change-Id: I1366eda606ddfb019637b09c82d8b0e30bd4e318
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7797
Tested-by: BuildkiteCI
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'users/Profpatsch/shell.nix')
-rw-r--r--users/Profpatsch/shell.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/users/Profpatsch/shell.nix b/users/Profpatsch/shell.nix
index cde599a8b4..499109ec37 100644
--- a/users/Profpatsch/shell.nix
+++ b/users/Profpatsch/shell.nix
@@ -37,6 +37,7 @@ pkgs.mkShell {
       h.hspec-expectations-pretty-diff
       depot.users.Profpatsch.my-prelude
       depot.users.Profpatsch.netencode.netencode-hs
+      depot.users.Profpatsch.arglib.netencode.haskell
       depot.users.Profpatsch.execline.exec-helpers-hs
 
     ]))