about summary refs log tree commit diff
path: root/users/Profpatsch/shell.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2024-02-11T16·31+0100
committerProfpatsch <mail@profpatsch.de>2024-02-11T16·38+0000
commit80c683c9ecf0129b5468028856a1443d87c6c64a (patch)
tree1e83ff04313ed98c6ae60edcc38a525ec63f065f /users/Profpatsch/shell.nix
parentd2e3f8cd7bd4599f5d7e57b0887eff922d5e4a44 (diff)
feat(declib): initial mastodon bot experiment r/7499
No default.nix yet, just for development.

Change-Id: Ib8bd0057d697fecd083d5961e635c770b7638e08
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10803
Reviewed-by: Profpatsch <mail@profpatsch.de>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--users/Profpatsch/shell.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/users/Profpatsch/shell.nix b/users/Profpatsch/shell.nix
index 367ab01e1d..1e36dbeda6 100644
--- a/users/Profpatsch/shell.nix
+++ b/users/Profpatsch/shell.nix
@@ -61,6 +61,8 @@ pkgs.mkShell {
     pkgs.pkg-config
     pkgs.fuse
     pkgs.postgresql
+    pkgs.nodejs
+    pkgs.ninja
   ];
 
   WHATCD_RESOLVER_TOOLS = pkgs.linkFarm "whatcd-resolver-tools" [
@@ -70,6 +72,8 @@ pkgs.mkShell {
     }
   ];
 
+  # DECLIB_MASTODON_ACCESS_TOKEN read from `pass` in .envrc.
+
   RUSTC_WRAPPER =
     let
       wrapperArgFile = libs: pkgs.writeText "rustc-wrapper-args"