about summary refs log tree commit diff
path: root/users/Profpatsch/netstring/tests.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2021-01-23T15·17+0100
committerProfpatsch <mail@profpatsch.de>2021-01-23T15·33+0000
commitcc3f54a0eedb579c2ffd76f0505af0ccf940f9ff (patch)
tree7a0e5b734fb0760f49ab41fdd6f9129f84d7caa1 /users/Profpatsch/netstring/tests.nix
parentea9982d9eab50ee724eb1e5bae000911b219472f (diff)
feat(users/Profpatsch/netstring): add rust to_netstring r/2137
Change-Id: I539472fc9ebc3ebe6c34e01fde9c08d3e2e3558c
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2431
Reviewed-by: Profpatsch <mail@profpatsch.de>
Tested-by: BuildkiteCI
Diffstat (limited to 'users/Profpatsch/netstring/tests.nix')
-rw-r--r--users/Profpatsch/netstring/tests.nix33
1 files changed, 24 insertions, 9 deletions
diff --git a/users/Profpatsch/netstring/tests.nix b/users/Profpatsch/netstring/tests.nix
index 0d4cee52766b..23141472d6a8 100644
--- a/users/Profpatsch/netstring/tests.nix
+++ b/users/Profpatsch/netstring/tests.nix
@@ -1,14 +1,9 @@
-{ depot, lib, pkgs, python-netstring, toNetstring, toNetstringKeyVal }:
+{ depot, lib, pkgs, python-netstring, rust-netstring, toNetstring, toNetstringKeyVal }:
 
 let
-  imports = {
-    inherit (depot.users.Profpatsch)
-      writers
-      ;
-  };
-
-  python-netstring-test = imports.writers.python3 {
-    name = "python-netstring";
+
+  python-netstring-test = depot.users.Profpatsch.writers.python3 {
+    name = "python-netstring-test";
     libraries = p: [
       python-netstring
     ];
@@ -36,11 +31,31 @@ let
       ),
       { b'foo': b'42', b'bar': b'hi' }
     )
+  '';
 
+  rust-netstring-test = depot.users.Profpatsch.writers.rustSimple {
+    name = "rust-netstring-test";
+    dependencies = [
+      rust-netstring
+    ];
+  } ''
+    extern crate netstring;
+
+    fn main() {
+      assert_eq!(
+        std::str::from_utf8(&netstring::to_netstring(b"hello")).unwrap(),
+        r##"${toNetstring "hello"}"##
+      );
+      assert_eq!(
+        std::str::from_utf8(&netstring::to_netstring("こんにちは".as_bytes())).unwrap(),
+        r##"${toNetstring "こんにちは"}"##
+      );
+    }
   '';
 
 in {
   inherit
     python-netstring-test
+    rust-netstring-test
     ;
 }