about summary refs log tree commit diff
path: root/users/Profpatsch/napalm.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2024-12-05T18·11+0100
committerProfpatsch <mail@profpatsch.de>2024-12-10T15·34+0000
commit6477428c36aa7fdb23cca2c2668659e1678f3b73 (patch)
tree02dde96216bd0218706a17285adf5e7a921afba7 /users/Profpatsch/napalm.nix
parent22c46c80093948aa2490220608f188d1691c8ad0 (diff)
feat(pkgs/Profpatsch/alacritty): init dark mode dbus daemon r/8996
A simple dbus daemon that writes the alacritty config to
`~/.config/alacritty/alacritty-colors-autogen.toml` on startup and
whenever a change between dark/light mode is requested.

Alacritty only implements an config file isync watcher, no SIGHUP
handler or similar, so we have to actually write the config file lol.

This is all a little glue-y, but idk, whatever.

Further reading & inspo:

https://github.com/alacritty/alacritty/issues/5999
https://www.christianfosli.com/posts/2024-on-colorscheme-changed/
https://github.com/christianfosli/on-colorscheme-changed

Change-Id: Iac4eb9d85679dc87e28e57d68384645b3b91d08a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/12870
Tested-by: BuildkiteCI
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'users/Profpatsch/napalm.nix')
-rw-r--r--users/Profpatsch/napalm.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/users/Profpatsch/napalm.nix b/users/Profpatsch/napalm.nix
new file mode 100644
index 000000000000..44c5885bd05e
--- /dev/null
+++ b/users/Profpatsch/napalm.nix
@@ -0,0 +1,9 @@
+{ pkgs, ... }:
+import
+  (builtins.fetchGit {
+    url = "https://github.com/nix-community/napalm";
+    rev = "e1babff744cd278b56abe8478008b4a9e23036cf";
+  })
+{
+  inherit pkgs;
+}