about summary refs log tree commit diff
path: root/users/Profpatsch/lens.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2022-01-30T16·06+0300
committertazjin <tazjin@tvl.su>2022-01-31T16·11+0000
commitaa122cbae78ce97d60c0c98ba14df753d97e40b1 (patch)
tree12b98d85c4b18fe870feb26de70db9ba61837bd7 /users/Profpatsch/lens.nix
parent2d10d60fac0fd00a71b65cfdcb9fba0477b2086c (diff)
style: format entire depot with nixpkgs-fmt r/3723
This CL can be used to compare the style of nixpkgs-fmt against other
formatters (nixpkgs, alejandra).

Change-Id: I87c6abff6bcb546b02ead15ad0405f81e01b6d9e
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4397
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Reviewed-by: wpcarro <wpcarro@gmail.com>
Reviewed-by: Profpatsch <mail@profpatsch.de>
Reviewed-by: kanepyork <rikingcoding@gmail.com>
Reviewed-by: tazjin <tazjin@tvl.su>
Reviewed-by: cynthia <cynthia@tvl.fyi>
Reviewed-by: edef <edef@edef.eu>
Reviewed-by: eta <tvl@eta.st>
Reviewed-by: grfn <grfn@gws.fyi>
Diffstat (limited to 'users/Profpatsch/lens.nix')
-rw-r--r--users/Profpatsch/lens.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/users/Profpatsch/lens.nix b/users/Profpatsch/lens.nix
index 58d9c27f52..28f7506bdd 100644
--- a/users/Profpatsch/lens.nix
+++ b/users/Profpatsch/lens.nix
@@ -32,7 +32,7 @@ let
     inherit fst snd;
   };
 
-  swap = {fst, snd}: {
+  swap = { fst, snd }: {
     fst = snd;
     snd = fst;
   };
@@ -71,7 +71,7 @@ let
   lensP = strong: to: pab:
     strong.dimap
       to
-      ({fst,snd}: snd fst)
+      ({ fst, snd }: snd fst)
       (strong.firstP pab);
 
   # first element of a tuple
@@ -112,7 +112,8 @@ let
       (map (accessor: accessor profunctorSubclass) accessors);
 
 
-in {
+in
+{
   inherit
     id
     _