about summary refs log tree commit diff
path: root/users/Profpatsch/ical-smolify/default.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2022-09-16T20·57+0200
committerProfpatsch <mail@profpatsch.de>2022-09-16T21·18+0000
commitdb093ad10c0228b017486cc59b7edd691b1b1b73 (patch)
tree7927a62ddbdcc578d38c461c5cc60dd0f1f2c34f /users/Profpatsch/ical-smolify/default.nix
parent0532cb61720355f5917c467440eb2b3cb297f2ba (diff)
feat(users/Profpatsch): init ical-smolify r/4880
ical, but smol

to fit in qr

Change-Id: I37f99a20cfc96b85778a097b7c4f70923f026cd4
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6617
Autosubmit: Profpatsch <mail@profpatsch.de>
Tested-by: BuildkiteCI
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'users/Profpatsch/ical-smolify/default.nix')
-rw-r--r--users/Profpatsch/ical-smolify/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/users/Profpatsch/ical-smolify/default.nix b/users/Profpatsch/ical-smolify/default.nix
new file mode 100644
index 000000000000..f67d175ce3f3
--- /dev/null
+++ b/users/Profpatsch/ical-smolify/default.nix
@@ -0,0 +1,16 @@
+{ depot, pkgs, lib, ... }:
+
+let
+  cas-serve = pkgs.writers.writeHaskell "ical-smolify"
+    {
+      libraries = [
+        pkgs.haskellPackages.iCalendar
+        depot.users.Profpatsch.my-prelude
+        depot.users.Profpatsch.execline.exec-helpers-hs
+
+      ];
+      ghcArgs = [ "-threaded" ];
+    } ./IcalSmolify.hs;
+
+in
+cas-serve