about summary refs log tree commit diff
path: root/users/Profpatsch/execline/default.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2022-08-20T00·32+0200
committerProfpatsch <mail@profpatsch.de>2022-08-22T12·47+0000
commit0fc16342554d293438a62a96adec4f48dac09d54 (patch)
tree917f97b9748c6c07b0bd18fe834d76f3a4cc786a /users/Profpatsch/execline/default.nix
parent240edcd2895aed2a929d4cae61b0f19a35560e4a (diff)
feat(users/Profpatsch): init haskell exec-helpers r/4447
Mirrors the rust exec-helpers

Change-Id: I8fba49525949a8f38ca8c215e2ec7ba9d97d3bf9
Reviewed-on: https://cl.tvl.fyi/c/depot/+/6116
Tested-by: BuildkiteCI
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'users/Profpatsch/execline/default.nix')
-rw-r--r--users/Profpatsch/execline/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/users/Profpatsch/execline/default.nix b/users/Profpatsch/execline/default.nix
index 752774e6ad0c..9b8856a9a84a 100644
--- a/users/Profpatsch/execline/default.nix
+++ b/users/Profpatsch/execline/default.nix
@@ -7,6 +7,23 @@ let
     }
     (builtins.readFile ./exec_helpers.rs);
 
+  exec-helpers-hs = pkgs.haskellPackages.mkDerivation {
+    pname = "exec-helpers";
+    version = "0.1.0";
+
+    src = depot.users.Profpatsch.exactSource ./. [
+      ./exec-helpers.cabal
+      ./ExecHelpers.hs
+    ];
+
+    libraryHaskellDepends = [
+      depot.users.Profpatsch.my-prelude
+    ];
+
+    isLibrary = true;
+    license = lib.licenses.mit;
+  };
+
   print-one-env = depot.nix.writers.rustSimple
     {
       name = "print-one-env";
@@ -32,6 +49,7 @@ in
 depot.nix.readTree.drvTargets {
   inherit
     exec-helpers
+    exec-helpers-hs
     print-one-env
     ;
 }