about summary refs log tree commit diff
path: root/users/Profpatsch/aerc.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2023-03-01T13·48+0100
committerProfpatsch <mail@profpatsch.de>2023-03-01T14·01+0000
commitde3eedff9be7e8bd1f6cc28ab51c7d54e0d59e9f (patch)
tree57d2f9697b5968049259462edde1da8308f8aa65 /users/Profpatsch/aerc.nix
parent48dfb8de0c5be05ead0ebf178e491ecd04212d1e (diff)
chore(users/Profpatsch): remove failed aerc experiment r/5865
I didn’t ever get aerc to work, so let’s get rid of this.

Change-Id: Ie59b23fe7d5af70ca82c1c624c1e11d21da735f4
Reviewed-on: https://cl.tvl.fyi/c/depot/+/8189
Autosubmit: Profpatsch <mail@profpatsch.de>
Tested-by: BuildkiteCI
Reviewed-by: Profpatsch <mail@profpatsch.de>
Reviewed-by: sterni <sternenseemann@systemli.org>
Diffstat (limited to 'users/Profpatsch/aerc.nix')
-rw-r--r--users/Profpatsch/aerc.nix54
1 files changed, 0 insertions, 54 deletions
diff --git a/users/Profpatsch/aerc.nix b/users/Profpatsch/aerc.nix
deleted file mode 100644
index 407f224e58..0000000000
--- a/users/Profpatsch/aerc.nix
+++ /dev/null
@@ -1,54 +0,0 @@
-{ depot, pkgs, lib, ... }:
-
-let
-  aerc-patched = pkgs.aerc.overrideAttrs (old: {
-    patches = old.patches or [ ] ++ [
-      ./aerc-no-config-perms.patch
-    ];
-  });
-
-  bins = depot.nix.getBins aerc-patched [ "aerc" ];
-
-  config =
-    depot.users.Profpatsch.importDhall.importDhall
-      {
-        root = ./.;
-        files = [
-          "aerc.dhall"
-          "dhall/lib.dhall"
-          "ini/ini.dhall"
-        ];
-        main = "aerc.dhall";
-        deps = [
-        ];
-      }
-      {
-        aercFilter = name: "${aerc-patched}/share/aerc/filters/${name}";
-        "Ini/externs" = depot.users.Profpatsch.ini.externs;
-      };
-
-  aerc-config = pkgs.linkFarm "alacritty-config" [
-    {
-      name = "aerc/accounts.conf";
-      path = pkgs.writeText "accounts.conf" config.accounts;
-    }
-    {
-      name = "aerc/aerc.conf";
-      path = pkgs.writeText "aerc.conf" config.aerc;
-    }
-    {
-      name = "aerc/binds.conf";
-      path = pkgs.writeText "binds.conf" config.binds;
-    }
-  ];
-
-  aerc = depot.nix.writeExecline "aerc" { } [
-    "export"
-    "XDG_CONFIG_HOME"
-    aerc-config
-    bins.aerc
-    "$@"
-  ];
-
-in
-aerc