about summary refs log tree commit diff
path: root/universe/default.nix
diff options
context:
space:
mode:
authorWilliam Carroll <wpcarro@gmail.com>2020-01-29T14·29+0000
committerWilliam Carroll <wpcarro@gmail.com>2020-01-29T14·29+0000
commitfb9380ba268b3cd27372acadb87b14cc96163374 (patch)
treef65d7fc8d8726499165a0949af39afd1abc8118c /universe/default.nix
parent15110e6de9f85537c7847267caa35fa068aea001 (diff)
parent8ad51b24dd8719840aac47134835ea25cfe1b0b8 (diff)
Add 'universe/' from commit '8ad51b24dd8719840aac47134835ea25cfe1b0b8'
git-subtree-dir: universe
git-subtree-mainline: 15110e6de9f85537c7847267caa35fa068aea001
git-subtree-split: 8ad51b24dd8719840aac47134835ea25cfe1b0b8
Diffstat (limited to 'universe/default.nix')
-rw-r--r--universe/default.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/universe/default.nix b/universe/default.nix
new file mode 100644
index 000000000000..ff4f40d8f943
--- /dev/null
+++ b/universe/default.nix
@@ -0,0 +1,37 @@
+# At the time of this writing, this configuration was taken from @tazjin's
+# default.nix from his depot. I've added, changed, and removed that parts that I
+# don't need, and this is what remains.
+{ ... }@args:
+
+with builtins;
+
+let
+  fix = f: let x = f x; in x;
+
+  # Global configuration that all packages are called with.
+  config = pkgs: {
+    inherit pkgs;
+  };
+
+  readTree' = import ~/depot/nix/readTree {};
+
+  # TODO: Find a better way to expose entire monorepo without introducing
+  # "infinite recursion".
+  localPkgs = readTree: {
+    blog = readTree ./blog;
+    lisp = readTree ./lisp;
+    third_party = readTree ./third_party;
+  };
+in fix(self: {
+  config = config self;
+
+  # Expose readTree for downstream repo consumers.
+  readTree = {
+    __functor = x: (readTree' x.config);
+    config = self.config;
+  };
+}
+
+# Add local packages as structured by readTree
+// (localPkgs (readTree' (self.config // { inherit (self) lib; })))
+)