about summary refs log tree commit diff
path: root/tvix/verify-lang-tests/default.nix
diff options
context:
space:
mode:
authorAdam Joseph <adam@westernsemico.com>2022-10-19T04·54-0700
committerclbot <clbot@tvl.fyi>2022-11-04T01·46+0000
commit9c7d8e791af7f6bfd4e518120cef4e36ba087fd6 (patch)
treeadd8e2b55d36768a7b6edcdd19018151a3e4bc16 /tvix/verify-lang-tests/default.nix
parent4ec43bed5e1f6077402301aeee125870f755267b (diff)
test(tvix/eval): add a test case for groupBy with thunks r/5242
We have to be careful implementing `builtins.groupBy`, since the
list may contain thunks, and tvix's to_xxx() functions do not work
on thunks.

Signed-off-by: Adam Joseph <adam@westernsemico.com>
Change-Id: I182b6fc2d4296f864ed16744ef70b153e8e6978a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/7039
Reviewed-by: tazjin <tazjin@tvl.su>
Tested-by: BuildkiteCI
Diffstat (limited to '')
-rw-r--r--tvix/verify-lang-tests/default.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/tvix/verify-lang-tests/default.nix b/tvix/verify-lang-tests/default.nix
index ca7ea4b348..b526085bb9 100644
--- a/tvix/verify-lang-tests/default.nix
+++ b/tvix/verify-lang-tests/default.nix
@@ -56,6 +56,8 @@ let
     "eval-okay-compare-lists.nix" = [ nix ];
     # getAttrPos gains support for functionArgs-returned sets after 2.3
     "eval-okay-getattrpos-functionargs.nix" = [ nix ];
+    # groupBy appeared (long) after 2.3
+    "eval-okay-builtins-groupby-thunk.nix" = [ nix ];
   };
 
   runCppNixLangTests = cpp-nix: