about summary refs log tree commit diff
path: root/tvix/verify-lang-tests/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2023-08-21T21·45+0300
committertazjin <tazjin@tvl.su>2023-09-06T13·38+0000
commit110328232ddee8aec755142e3098ba07914b8322 (patch)
tree5e865d27ab4fe44b27ac9e7e352778cf16fc14d4 /tvix/verify-lang-tests/default.nix
parent1aa8b62ae31055beb435a310a22a9ca3c9c8e63c (diff)
chore(3p/sources): bump channels & overlays (2023-08-21) r/6560
Included changes:

* tvix/eval: enable some lang tests on nix_latest

  Nix 2.16 contains some breaking language changes which Tvix does
  not yet implement, but the existing tests for them are now passed by
  Nix 2.16 (but not yet by Tvix).

* tvix/eval: disable a lang test on nix_latest

  In Nix 2.17, the identifier formatting test fails because some
  behaviour changed. We have not investigated further yet.

* 3p/overlays: use version of ihp-hsx that works with GHC 9.4

  Originally from the separate cl/9185.

* top-level: introduce a mechanism to exclude build targets from CI in
  the top level. This fixes b/296.

* users/grfn: disable builds of xanthous (and dependents) until the
  CLs fixing its build are submitted

* 3p/overlays: build nixos-option against Nix 2.15, the only version
  with which it builds

* 3p/overlays: bump tdlib to 1.8.16

Change-Id: Ia377f39dbdb08ac45ff830a615e64babc091e5ee
Reviewed-on: https://cl.tvl.fyi/c/depot/+/9125
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Autosubmit: tazjin <tazjin@tvl.su>
Diffstat (limited to '')
-rw-r--r--tvix/verify-lang-tests/default.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/tvix/verify-lang-tests/default.nix b/tvix/verify-lang-tests/default.nix
index 54fa0f908c..caf7235b8b 100644
--- a/tvix/verify-lang-tests/default.nix
+++ b/tvix/verify-lang-tests/default.nix
@@ -36,8 +36,6 @@ let
           ]
       ) [ "nix_tests" "nix_tests/notyetpassing" "tvix_tests" "tvix_tests/notyetpassing" ];
 
-  latestNixIs215 = lib.versionOlder nix_latest.version "2.16";
-
   skippedLangTests = {
     # TODO(sterni): set up NIX_PATH in sandbox
     "eval-okay-search-path.nix" = true;
@@ -67,11 +65,14 @@ let
     # Cycle detection and formatting changed sometime after Nix 2.3
     "eval-okay-cycle-display-cpp-nix-2.13.nix" = [ nix ];
     # builtins.replaceStrings becomes lazier in Nix 2.16
-    "eval-okay-replacestrings.nix" = [ nix (assert latestNixIs215; nix_latest) ];
+    "eval-okay-replacestrings.nix" = [ nix ];
     # builtins.readFileType is added in Nix 2.15
     "eval-okay-readFileType.nix" = [ nix ];
     # builtins.fromTOML gains support for timestamps in Nix 2.16
-    "eval-okay-fromTOML-timestamps.nix" = [ nix (assert latestNixIs215; nix_latest) ];
+    "eval-okay-fromTOML-timestamps.nix" = [ nix ];
+    # identifier formatting seems to have changed in Nix 2.17
+    # TODO: figure out why, this is just to get the bump in cl/9125 working.
+    "eval-okay-identifier-formatting.nix" = [ nix_latest ];
 
     # TODO(sterni): support diffing working directory and home relative paths
     # like C++ Nix test suite (using string replacement).