about summary refs log tree commit diff
path: root/tvix/utils.nix
diff options
context:
space:
mode:
authorIlan Joselevich <personal@ilanjoselevich.com>2024-07-04T18·43+0300
committerclbot <clbot@tvl.fyi>2024-07-05T20·07+0000
commit63654fbeb16278e21b8c5131fb402c7c98da5489 (patch)
treebb1c2faf8d8fcc47af30c3278d9ebac67174a853 /tvix/utils.nix
parentfc63594631590547c9a31001806095f2e079a20e (diff)
fix(tvix/utils): Optionally add support for Cargo in filterRustCrateSrc r/8347
Previously we would unconditionally add Cargo.toml to the fileset. We
mostly use buildRustCrate in tvix so it does not make sense to add it by
default, instead I made it so you enable cargoSupport if you want
Cargo.{toml,lock} to be added to the fileset.

Change-Id: I5a6016534fc5599e85ab581fe3d9b81e7a24f940
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11950
Reviewed-by: flokli <flokli@flokli.de>
Tested-by: BuildkiteCI
Autosubmit: Ilan Joselevich <personal@ilanjoselevich.com>
Diffstat (limited to '')
-rw-r--r--tvix/utils.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/tvix/utils.nix b/tvix/utils.nix
index 5edc1dc2e856..0bb9323d684d 100644
--- a/tvix/utils.nix
+++ b/tvix/utils.nix
@@ -22,21 +22,23 @@
       (powerset features));
 
   # Filters the given source, only keeping files related to the build, preventing unnecessary rebuilds.
-  # Includes src in the root, all other .rs files, as well as Cargo.toml.
+  # Includes src in the root, all other .rs files and optionally Cargo specific files.
   # Additional files to be included can be specified in extraFileset.
   filterRustCrateSrc =
     { root # The original src
     , extraFileset ? null # Additional filesets to include (e.g. fileFilter for proto files)
+    , cargoSupport ? false
     }:
     lib.fileset.toSource {
       inherit root;
-      fileset = (lib.fileset.intersection
+      fileset = lib.fileset.intersection
         (lib.fileset.fromSource root) # We build our final fileset from the original src
         (lib.fileset.unions ([
           (root + "/src")
           (lib.fileset.fileFilter (f: f.hasExt "rs") root)
-          # We assume that every Rust crate will at a minimum have .rs files and a Cargo.toml
+        ] ++ lib.optionals cargoSupport [
           (lib.fileset.fileFilter (f: f.name == "Cargo.toml") root)
-        ] ++ lib.optional (extraFileset != null) extraFileset)));
+          (lib.fileset.maybeMissing (root + "/Cargo.lock"))
+        ] ++ lib.optional (extraFileset != null) extraFileset));
     };
 }