about summary refs log tree commit diff
path: root/tvix/tracing/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2024-06-14T11·10+0300
committerflokli <flokli@flokli.de>2024-06-14T19·33+0000
commit6b6a34065e050417e8aafab8915a2cee270cc09d (patch)
treef30975995e430586439897109221e38f9e70b159 /tvix/tracing/default.nix
parentd25f047b9d12bab692e61f6bbdc4c8d673914f34 (diff)
feat(tvix/tracing): add tracing-tracy support r/8275
This introduces another feature flag, "tracy" to the `tvix-tracing` crate.

If enabled (not enabled by default), it'll add an additional layer
emitting packets in a format that https://github.com/wolfpld/tracy can
display.

I had to be a bit tricky with the combinatorial complexity when adding
this, but the resulting code still seems manageable.

Change-Id: Ica824496728fa276ceae3f7a9754be0166e6558f
Reviewed-on: https://cl.tvl.fyi/c/depot/+/10952
Tested-by: BuildkiteCI
Reviewed-by: Simon Hauser <simon.hauser@helsinki-systems.de>
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/tracing/default.nix')
-rw-r--r--tvix/tracing/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tvix/tracing/default.nix b/tvix/tracing/default.nix
index a4fe3a5d90c3..dd7dc200f2c6 100644
--- a/tvix/tracing/default.nix
+++ b/tvix/tracing/default.nix
@@ -6,6 +6,6 @@
   meta.ci.targets = lib.filter (x: lib.hasPrefix "with-features" x || x == "no-features") (lib.attrNames passthru);
   passthru = depot.tvix.utils.mkFeaturePowerset {
     inherit (old) crateName;
-    features = [ "otlp" ];
+    features = [ "otlp" "tracy" ];
   };
 })