about summary refs log tree commit diff
path: root/tvix/tracing/default.nix
diff options
context:
space:
mode:
authorSimon Hauser <simon.hauser@helsinki-systems.de>2024-07-02T10·50+0200
committerSimon Hauser <simon.hauser@helsinki-systems.de>2024-07-21T05·45+0000
commit1515a970bedbb6d7b5e8f966dddd0d8fff9bb03c (patch)
treef5ef8111a7a13e213fa0963bb689fd331b2d209d /tvix/tracing/default.nix
parentfdc0cf0c94827fc4940c9f8ac4d310d57aec9f35 (diff)
feat(tvix/tracing): http propagation for axum r/8384
It introduces a new accept_trace function for axum0.7 which can be used
to accept a header trace from a received request. This function can be
used for tonic 0.12 once that version is released, and the specific
`accept_trace` function within `tvix_tracing::propagate::tonic` can then
be removed.

This also integrates http propagation into the nar_bridge crate.

Change-Id: I46dcc797d494bb3977c2633753e7060d88d29129
Reviewed-on: https://cl.tvl.fyi/c/depot/+/11925
Reviewed-by: Brian Olsen <me@griff.name>
Tested-by: BuildkiteCI
Reviewed-by: Simon Hauser <simon.hauser@helsinki-systems.de>
Reviewed-by: flokli <flokli@flokli.de>
Diffstat (limited to 'tvix/tracing/default.nix')
-rw-r--r--tvix/tracing/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tvix/tracing/default.nix b/tvix/tracing/default.nix
index a4ac9de1c8bc..ef1985cb47fb 100644
--- a/tvix/tracing/default.nix
+++ b/tvix/tracing/default.nix
@@ -6,6 +6,6 @@
   meta.ci.targets = lib.filter (x: lib.hasPrefix "with-features" x || x == "no-features") (lib.attrNames passthru);
   passthru = depot.tvix.utils.mkFeaturePowerset {
     inherit (old) crateName;
-    features = [ "otlp" "tracy" "tonic" "reqwest" ];
+    features = [ "otlp" "tracy" "tonic" "reqwest" "axum" ];
   };
 })